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How to Use Windows Debugger to Troubleshoot Bluescreens

Summary: Learn how to download Windows Debugger (WinDbg) and run it to read minidump files and troubleshoot bluescreen errors in a Windows operating system.

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Article Content


Symptoms

If your computer experiences a bluescreen, how can you find out what happened, fix the issue and it prevent it from happening again? You may find the memory dump file useful in this situation. The memory dump file contains the smallest amount of useful information that could help you identify why your computer experienced a bluescreen. Windows Debugger, also known as WinDbg, is a tool made by Microsoft to help troubleshoot bluescreen minidumps. Windows Debugger is a tool that helps you read the minidump file.

The memory dump file contains the following information:

  • The stop message, its parameters, and other data
  • A list of loaded drivers
  • The processor context (PRCB) for the processor that stopped
  • The process information and kernel context (EPROCESS) for the process that stopped
  • The process information and kernel context (ETHREAD) for the thread that stopped
  • The Kernel-mode call stack for the thread that stopped

Affected Operating Systems:

  • Windows 11
  • Windows 10

Cause

Causes for blue screen errors vary. Hardware failures or software corruption are both possible.

Resolution

To use Windows Debugger, Install and Run WinDbg Preview, Analyze a Dump File, then Review the Analysis Results. You may also Use the Driver Verifier Tool to Gather Information. Click the appropriate subject for more information.

Install and Run

  1. Search for WinDbg in the Microsoft Store and then download WinDbg Preview.

Downloading WinDbg Preview
Figure 1: Downloading WinDbg Preview

  1. After installing the app, open WinDbg Preview from Windows Search.

Opening WinDbg
Figure 2: Opening WinDbg

Analyze a Dump File

  1. Click the File menu.
  2. Click Settings, click Debugging settings, and then locate the Default symbol path. In the Default symbol path, type srv*https://msdl.microsoft.com/download/symbols and then click OK.

Setting a default symbol path
Figure 3: Setting a default symbol path

Note: For more information about the symbol path, reference Symbol path for Windows debuggers This hyperlink is taking you to a website outside of Dell Technologies..
  1. Click File, click Open source file, and then click Open dump file. From here, Browse to a dump file and then click Open.

Opening a dump file
Figure 4: Opening a dump file

Note: Crash dump files for apps and Windows dump files may be analyzed after browsing to the appropriate location of the Dump File. For example, two common locations to check for dump files are:
  • C:\Users\XYZ\AppData\Local\CrashDumps\
  • C:\Windows\Minidump\
  1. Analyze the file by typing !analyze -v and then press Enter.

Running the analyze command
Figure 5: Running the analyze command

  1. Once the analysis is complete, Windows Debugger shows the file causing the bluescreen. Review the analysis MODULE_NAME or IMAGE_NAME for the file. Reviewing the results can lead to further troubleshooting steps and potentially reveal the cause of the error.

Reviewing the analysis
Figure 6: Reviewing the analysis

Review the Analysis Results

For more information about the error, reference the Bug Check Codes from Bug Check Code ReferenceThis hyperlink is taking you to a website outside of Dell Technologies..

For more information about blue screen error code confirmation links, reference Advanced Troubleshooting for Stop or Blue Screen ErrorsThis hyperlink is taking you to a website outside of Dell Technologies..

For more information about file Information, reference Process ExplorerThis hyperlink is taking you to a website outside of Dell Technologies..

For more information about resolving blue screens, reference Resolving Blue Screen errors in WindowsThis hyperlink is taking you to a website outside of Dell Technologies..

For more information about Windows Debugger, reference Analyze a kernel-mode dump file by using WinDbgThis hyperlink is taking you to a website outside of Dell Technologies..

For more information about the analyze extension, reference Using the !analyze ExtensionThis hyperlink is taking you to a website outside of Dell Technologies. and !analyze (WinDbg)This hyperlink is taking you to a website outside of Dell Technologies..

Use the Driver Verifier Tool to Gather Information

Approximately 75% of blue screen errors are caused by driver issues. The Driver Verifier tool runs in real-time to examine the behavior of installed drivers. The driver verifier manager is built into Windows and is available on all Windows computers.

Follow these steps to start the driver verifier manager:

  1. Click Search in the Taskbar and type CMD in the field.
  2. Right-click Command Prompt and select Run as administrator.
  3. Type Verifier in Command Prompt.

You can specify which drivers you would like to verify. The verify tool adds all drivers associated to the driver being verified as it runs, so try to verify the smallest number of drivers as possible. For more information, see Driver VerifierThis hyperlink is taking you to a website outside of Dell Technologies..

Additional Information

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Last Published Date

08 Mar 2024

Version

8

Article Type

Solution