Latitude E6510 Supports DW5620 and DW5540 Broadband Cards for use with TELUS

Latitude E6510 Supports DW5620 and DW5540 Broadband Cards for use with TELUS


Canadian users that have a Latitude E6510 with a DW5720 broadband card may find it is not compatible with the Internet Service Provider (ISP) TELUS. It is recommended to replace the DW5720 card with either a DW5620 or a DW5540 card that supports TELUS.



The drivers for the DW5620 and DW5540 cards are available for the E6510 on support.dell.com. Use the DW5720 and the DW5730 cards at your own risk with the Latitude E6510, because there are no Dell supported drivers for these cards.


文章ID: SLN70819

上次修改日期: 12/04/2014 09:36 AM


评价此文章

准确性
有用性
易理解性
这篇文章对您有帮助吗?
向我们发送反馈
注释中不得包含以下特殊字符:<>()\
抱歉,我们的反馈系统目前发生故障。请稍后重试。

感谢您提供反馈。