Preparing VMware ESXi Hosts To Attach to SCv20x0, SCv30x0, SC4020, SC5020 SAS Arrays

Preparing VMware ESXi Hosts To Attach to SCv20x0, SCv30x0, SC4020, SC5020 SAS Arrays






Review the DELL Storage Compatibility Matrix for the supported driver and firmware
  • ESXi 5.5 and 6.0 require the "mpt3sas" driver and must be downloaded from the VMware website.
    • The Dell customized ESX 5.5 & 6.0 ISOs will NOT automatically load the proper SAS HBA driver. The driver must be updated.
    • Using the native inbox driver will result in the HBA(s) being unable to see any volumes in ESX.
  • ESXi 6.5 requires the "lsi_msgpt3" driver and the inbox driver can be used. However, different ISO image will use different drivers by default.
    • Dell EMC recommends using the Dell customized ISO for VMware on Dell EMC PowerEdge servers. The ISO can be located under the Enterprise Solutions section for the Drivers and Download page on Dell's website .
    • The Dell customized ESX 6.5 ISO will automatically load the proper SAS HBA driver.
    • If using the standard VMware ESX 6.5 ISO, the correct in box SAS HBA driver will need to be enabled.
These procedures align with steps outlined in step 4 of the SCv20x0 installation poster that shipped with the system or chapter 3 in the Deployment Guide.
To attach an ESX host with SAS HBAs to the Storage Center array, the DSM Data Collector must be used. Connecting the DSM Client directly to the array is currently not supported.


Determine what driver is enabled:
  1. Enable SSH on the ESXi Host:
    1. Login to the ESXi host with vSphere Client
    2. Select "Configuration" tab, then select "Security Profile" in Software menu.
    3. In the Services area, select "Properties".
    4. Select "SSH" then click on the button "Options".
    5. Click "Start" and confirm with "OK".
  2. Connect to ESXi Host using SSH Client (such as Putty).
  3. Determine what driver is running. This can be done by typing the following command: "esxcfg-scsidevs -a"

  1. If you are using a standard ESX 6.5 ISO image, you can disable the "mpt3sas" driver and enable the "lsi_msgpt3" driver with these commands:
  • esxcfg-module -d mpt3sas
  • esxcfg-module -e lsi_msgpt3
  1. For ESX 5.5 & 6.0; If you have the incorrect driver go to step 5a. If you have the correct driver listed, go to step 5b.
5a. Disable the incorrect driver by typing one of the following command
  • esxcli system module set --enabled=false --module=lsi_msgpt3. Go to step 6
5b. Verify that the driver version matches the one on the DELL Storage Compatibility Matrix: by typing the following command:
  • For the mpt3sas driver type "vmkload_mod -s mpt3sas |grep Version"

Updating Driver:
  1. Move all VM’s off of host, enter maintenance mode.
  2. Download the correct driver version as stated on the DELL Storage Compatibility Matrix: (As of this writing, the driver version is 04.00.00.00.1vmw for ESX 5.5 U2). The driver can be found on VMware website.
  3. Extract ".VIB" file from download "ZIP" driver package.
  4. Upload ".VIB" file to the ESXi host.
    1. On ESXi host interface, select "Configuration" tab.
    2. Select "Storage" in Configuration menu, then a datastore for uploading ".VIB" file.
      (If no datastore is available, you can use any FTP client and upload to the /tmp folder)
    3. Browse your datastore (by right-clicking on it), "Browse Datastore".
    4. Upload the ".VIB" file by selecting the "upload a file" icon.
  5. Install new driver (adjust your path and file name accordingly) by typing the following command: "esxcli software vib install -v /vmfs/volumes/ESXi01-Local/scsi-mpt3sas-04.00.00.00.1vmw-1OEM.500.0.0.472560.x86_64.vib"

  1. Reboot the VMware ESXi host.
  2. The HBA(s) should now have the correct driver loaded and should be able to work properly with Storage Center. You can verify this by repeating step 5b above.
The HBA firmware should also be updated using the iDRAC.

Artikel-ID: HOW11081

Datum der letzten Änderung: 03/26/2019 02:08 PM


Diesen Artikel bewerten

Präzise
Nützlich
Leicht verständlich
War dieser Artikel hilfreich?
Ja Nein
Schicken Sie uns Ihr Feedback.
Die folgenden Sonderzeichen dürfen in Kommentaren nicht verwendet werden: <>()\
Derzeit ist kein Zugriff auf das Feedbacksystem möglich. Bitte versuchen Sie es später erneut.

Vielen Dank für Ihr Feedback.