Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Article Number: 000179083


What is the IOMINF on a PowerEdge M1000e and how to update

Summary: This article provides information on the IOMINF firmware and provides information for performing the firmware update.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

What is the IOMINF on a PowerEdge M1000e and how do I update its firmware


What is the IOMINF
The IOM Infrastructure Device Firmware (IOMINF) is the component interface circuitry between the IOM Device (Fabric Device / IO Module) and the CMC.

Where does the firmware update exist?
The updated image for the component resides in the CMC File System.

How would I know that the IOM Infrastructure Device Firmware (IOMINF) needs to be updated?
The component displays as an updatable device on the CMC Web GUI (Update Tab / Firmware update page), and is only visible if the current revision on the component and the component image on the CMC do not match. If the IOMINF firmware is up-to-date, the CMC prevents IOMINF updates and will not show this section on the screen.

Is there a method for determining the current version of the IOM Firmware outside of the CMC GUI?
No, at this time the only method is within the CMC GUI.

If I have IOM Firmware to update, can I still update to newer CMC Firmware first?
Yes, update to the latest CMC Firmware first so that the most current IOMINF Firmware is available.

When should this update be performed?
If required, the update should be performed after the CMC update.
Please engage PowerConnect / Enterprise Networking Support team before performing the updates via the call directors

What happens during the IOMINF firmware update?
No file transfer timer is displayed when updating IOMINF firmware.
Note: The update process may cause a brief loss of connectivity to the IOM device since the device performs a restart when the update is complete. When the update is complete, the new firmware is displayed and the updated system is no longer present on the Firmware Update page.

How do I know which IOM the update is for?

A1=IOMINF-1
A2=IOMINF-2
B1=IOMINF-3
B2=IOMINF-4
C1=IOMINF-5
C2=IOMINF-6


How do I perform the IOMINF firmware update?
Reference the "Updating the IOM Infrastructure Device Firmware" for the version of firmware installed or being installed on the CMC.

1. Log in to the CMC Web interface
2. Select Chassis Overview in the system tree
3. Click the Update tab. The Firmware Update page appears
4. Select the IOM device to update by selecting the Update Targets check box for that IOM device
5. Click the Apply IOM Update button below the IOM component list.


Do I need to reboot the M1000e Chassis after applying the update?
No, the update will reboot the IOM Device, no reboot of the Chassis is required.

Will there be a loss of connectivity to the blades during the update?
Yes, as the IOM Device requires a reboot, the Blades attached to that IOM will lose connection. If there is no redundancy or failover established on the Blades to other IOM Devices it is recommended that this be performed during a maintenance window.

Can I update the IOMINF all at once or one at a time?
If multiple IOMINF's are selected the CMC will update these in sequence.

What is the order of updates for the M1000e
CMC Firmware
IOMINF Firmware
Blade BIOS Firmware
Blade Lifecycle Controller Firmware
Blade iDRAC Firmware
Blade CPLD Firmware (Optional)
Blade CPLD M910 Firmware (Required)
Blade Mezzanine Card Driver / Firmware
Blade Storage Controller Driver / Firmware
Blade LOM Driver / Firmware
IO Device Firmware
Recommended workflow for performing firmware updates on PowerEdge M1000e and modular servers

Cause

Need more help? 

See below.

Resolution

 

Article Properties


Affected Product

Servers

Last Published Date

17 Dec 2021

Version

6

Article Type

Solution