Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

How to Troubleshoot Dell Digital Delivery

Summary: The following article discusses how to troubleshoot missing software in Dell Digital Delivery.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Affected Products:

  • Dell Digital Delivery

Affected Versions:

  • v3.0 and Later

Dell Digital Delivery enables access to software purchased with a commercial or consumer Dell computer running Windows.

Note:

Cause

If Dell Digital Delivery does not display the purchased software, it is necessary to troubleshoot the Application before collecting Application Logs. Click the appropriate section for more information.

Resolution

Choose Application or Application Logs
Figure 1: (English Only) Choose Application or Application Logs

  1. Go to https://www.microsoft.com/ This hyperlink is taking you to a website outside of Dell Technologies..
    • Failure indicates either an unstable or no internet connection.
    • On success, go to next step.
  2. On success, verify firewall connectivity by going to https://cloud.dell.com/ClientServices/Client.svc/v1/Client/Config?r=en This hyperlink is taking you to a website outside of Dell Technologies.:
    • On success, the user gets a request to enter their credentials. This indicates that the computer can successfully communicate to the Dell cloud software service. Go to the Application section for additional troubleshooting.
    • Failure indicates that a firewall or proxy settings are blocking the URL.

User is requested to enter credentials
Figure 2: (English Only) Credentials Request

  1. Launch the Dell Digital Delivery application.
  2. In the bottom menu, click Click question mark at bottom of page.

Click Question Mark at bottom of page
Figure 3: (English Only) Click Question Mark at bottom of page

  1. Click REFRESH. This rebuilds the Dell Digital Delivery local software database cache.

Click REFRESH
Figure 4: (English Only) Click REFRESH

  1. Close the Dell Digital Delivery application.
  2. After 1 minute, launch the Dell Digital Delivery application.
  3. If issue persists, go to Application Logs to collect the appropriate information before contacting technical support.
Note: For more information reference How to Get Support for Dell Digital Delivery.
  1. Launch the Dell Digital Delivery application.
  2. In the bottom menu, click Help.

Click Help
Figure 5: (English Only) Click Help

  1. Click RESET NOW. This rebuilds the Dell Digital Delivery local software database cache.

Click RESET NOW
Figure 6: (English Only) Click RESET NOW

  1. Close the Dell Digital Delivery application.
  2. After 1 minute, launch the Dell Digital Delivery application.
  3. If issue persists, go to Application Logs to collect the appropriate information before contacting technical support.
Note: For more information reference How to Get Support for Dell Digital Delivery.

Version 4.0.92 and Later

  1. To assist with further troubleshooting reference instructions below for how to collect the following logs:
    • Service Logs: C:\ProgramData\dell\D3\Resources\SQLite
    • Database Logs: C:\ProgramData\dell\D3\Resources\Logs\serilog
    • UWP Logs: C:\users\<username>\appdata\local\packages\dellinc.DellDigitalDelivery_<x.x.xx.x>_x64__htrsf667h5kn2\LocalState\serilog
      • Where <username> = username; Example: John_Doe
      • Where <x.x.xx.x> = version or rev; Example: v4.0.92.0 (previous) or v5.0.49.0 (latest)
  2. To collect Service logs:
    1. Go to Windows Search and type C:\ProgramData\Dell\D3\Resources\Logs\serilog.
    2. Select the file explorer folder that is shown in the screenshot below.
    3. Collect these logs and provide them to the support agent for further assistance.

Go to C:\ProgramData\Dell\D3\Resources\Logs\serilog
Figure 7: (English Only) Go to C:\ProgramData\Dell\D3\Resources\Logs\serilog

Note:
  1. To collect DDD Database Logs:
    1. Go to Windows Search bar type C:\programdata\dell\d3\resources\SQLite.
    2. Select the folder that is shown in the screenshot below.
    3. Collect the logs and provide them to support agent for further assistance.

Go to c:\programdata\dell\d3\resources\SQLite
Figure 8: (English Only) Go to c:\programdata\dell\d3\resources\SQLite

  1. To collect Dell Digital Delivery UWP logs:
    1. Right-click the windows icon that is in the task and click Run as shown by the screenshot below.

Click Run
Figure 9: (English Only) Click Run

  1. In the Run user interface type %LOCALAPPDATA% and, select OK in the bottom left as shown by screenshot below.

Type %LOCALAPPDATA% and click OK
Figure 10: (English Only) Type %LOCALAPPDATA% and click OK

  1. A file explorer is displayed with several folders.
  2. Locate and click Packages folder.
  3. Once in the Packages folder, go to the search bar in the upper right corner and search DellDigitalDelivery.
  4. Click the folder as shown by the screenshot below.
Note: Folder name may vary based on Dell Digital Delivery application version.

Search for DellDigitalDelivery
Figure 11: (English Only) Search for DellDigitalDelivery

  1. Go to and click Local State folder then go to click seriallog folder. Collect the logs and provide them to support agent for further assistance.

Additional Information

Article Properties


Last Published Date

20 Dec 2023

Version

25

Article Type

Solution