Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Windows 10 - Task Manager Reports 100% Disk Utilization with MSI Mode Enabled

Summary: This article addresses a Windows 10 issue where Windows Task Manager might show 100% disk utilization on devices with Message Signaled Interrupt (MSI) mode enabled.

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

NOTE: This article is not intended to address all potential causes and contributing factors that are associated with a 100% Disk Utilization issue. This article addresses a specific cause as outlined by Microsoft.   


Symptoms of this issue include the following:

  • Task Manager reporting the hard disk to be operating at 100% utilization despite a light workload or no workload
  • The computer may experience lag or become unresponsive.
  • The computer event log contains numerous events with Event ID 129, which represent resets of the disk controller.

Cause

Microsoft reports that an issue exists with some Advanced Host Controller Interface PCI-Express (AHCI PCIe). Models that cause these symptoms in Windows 10 when running with the StorAHCI.sys driver. Due to a suspected firmware incompatibility, the Solid-state drive (SSD) does not properly complete input/output operations when Message Signaled Interrupt (MSI) mode is enabled in Windows 10. As a result, the Windows storage stack attempts to reset the device after encountering unresponsive read or write commands over time.

Resolution

Microsoft has provided the following steps to disable MSI mode for specific devices using the registry:

  1. Determine that the computer is running the default AHCI driver (StorAHCI.sys):
    1. Open a command prompt with administrator privileges. Then type devmgmt.msc in the command prompt window and press Enter.
    2. Under IDE ATA/ATAPI Controllers right-click the AHCI controller node and select Properties. This node is called "Standard SATA AHCI Controller."
    3. Click the Driver Details tab.
    4. If "StorAHCI.sys" is listed, the computer is running the default driver.
  2. Disable MSI for the controller in the registry:
    1. In the same properties window opened in step 1.2, browse the Details tab and select Device instance path from the Property drop-down menu. Note this path.
    2. Open the Registry Editor by typing regedit in the previously opened command prompt.
    3. Browse: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\PCI\<AHCI Controller>\Device Parameters\Interrupt Management\MessageSignaledInterruptProperties, (where <AHCI Controller> refers to the device instance path you noted in step 2.1).
    4. Change the value of the MSISupported key from " 1" to "0."
    5. If you do not know which controller your boot device is attached to, repeat steps 2.1 through 2.4 for all AHCI controllers that are found under 1.2.
  3. Reboot the computer.


If the steps above do not resolve the issue, the following steps may provide a workaround:
  1. Browse to Control Panel.
  2. Select System and Security.
  3. Select System.
  4. Select Advanced System Setting.
  5. Under Performance, Select Setting .
  6. Select the Advanced Tab.
  7. Select Change.
  8. Set the minimum to the amount of System Ram installed.
  9. Set the Maximum to double the amount of System Ram installed.
  10. Select Apply.
  11. Select OK.
  12. Restart the computer.
This process increases the size of the Pagefile that Windows uses to ensure that enough storage space is allocated to the Operating System.

Out of Warranty support Out of warranty? No problem. Browse to the Dell.com/support website and enter your Dell Service Tag and view our offers.

NOTE: Offers are only available for US, Canada, UK, France, Germany, China, and Japan personal computer customers. Server and Storage not applicable.

Article Properties


Last Published Date

20 Dec 2022

Version

6

Article Type

Solution