SC Storage Notification: Dell Storage Manager Virtual Appliance Unsuccessful Upgrade

Summary: A workaround for this issue on your Dell Storage product is supplied in this article.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

This notification pertains to Dell Storage Manager Virtual Appliance. It contains specific information related to system features or functionality.

Notification:
The Dell Storage Manager (DSM) Virtual Appliance was introduced with DSM version 2016. A potential issue has been identified with upgrading an existing DSM Virtual Appliance to a later DSM release which could result in an unsuccessful upgrade and leave the Virtual Appliance unusable.
Affected versions:
All current versions of Dell Storage Manager Virtual Appliance

Cause

A potential issue was identified with upgrading an existing DSM Virtual Appliance to a later DSM release which could result in an unsuccessful upgrade and leave the Virtual Appliance unusable.

Resolution

Workaround:
To mitigate the occurrence of an unsuccessful Virtual Appliance upgrade, implement the following procedure:

  1. Take a VM snapshot of the Virtual Appliance prior to any upgrade procedure being performed.
  2. Contact Dell Technical Support to log a case and to perform a Dell Storage Manager Virtual Appliance preupgrade check.
  3. Proceed with upgrade of the Virtual Appliance when approved by Dell Technical Support. Upgrade should complete within 30 minutes. If the upgrade has not completed within the allotted time, contact Dell Technical Support.
Resolution:
This is planned to be addressed in a future release of Dell Storage Manager Virtual Appliance.

Affected Products

Compellent (SC, SCv & FS Series), Legacy Storage Models
Article Properties
Article Number: 000136454
Article Type: Solution
Last Modified: 21 Aug 2025
Version:  4
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