Dell Endpoint Security Suite Pro System Requirements

Dell Endpoint Security Suite Pro System Requirements


This article covers the system requirements for installing Dell Endpoint Security Suite Pro.


Affected Products:

Dell Endpoint Security Suite Pro

Affected Versions:

1.0 and later

Affected Platforms:

Windows




Dell Endpoint Security Suite Pro integrates McAfee’s Threat Protection (Antivirus / Firewall/ Web Protection) client with Dell Encryption Enterprise (formerly Dell Data Protection | Enterprise Edition) security options:

  • Data-Centric Encryption
  • BitLocker Manager
  • Self-Encrypting Drive
  • External Media Encryption
  • Server Encryption

This article covers only McAfee client requirements. For information on the encryption requirements please reference the documentation at www.dell.com/support/home.

Note: The Threat Protection component cannot be installed without the Data-Centric Encryption client.

Server Infrastructure

Dell Endpoint Security Suite Pro requires Dell Security Management Server (formerly Dell Data Protection Server) version 9.0 or later for policy and key management.

Network Requirements:

Outbound traffic must be opened to the following destinations for any environment using Dell Endpoint Security Suite Pro. Alternatively, an existing HTTP/HTTPS proxy server may be used in place of direct connectivity through the firewall.

Destinations Protocol Port Purpose
vs.mcafeeasap.com HTTPS TCP 443
Failback 80
Engine /Signature Updates
tunnel.web.trustedsource.org HTTPS TCP 443 Reputation Service
gtifeedback.trustedsource.org HTTPS TCP 443 Reputation Service Feedback
list.smartfilter.com HTTPS TCP 443 URL Reputation Database Update

If Dell Endpoint Security Suite Pro uses On-the-Box (OTB) entitlements (licenses) then cloud.dell.com over port 443 must be whitelisted.

Minimum Hardware Requirements:

  • Intel Pentium or AMD class processor
  • 512GB RAM
  • 110MB of free disk space
    • Additional 250MB free disk space is required if using Dell pre-boot authentication (PBA)

General Requirements:

  • Local Administration rights.
  • Dell Endpoint Security Suite Pro license
  • Web Protection feature is supported with Internet Explorer only

Software Requirements:

Software requirements vary by version of Dell Endpoint Security Suite Pro. Click on the appropriate software version for more information.

Operating Systems (32 and 64 bit):

  • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate1
  • Windows 8 Enterprise, Pro2
  • Windows 8.1 Update 0-1, Enterprise, Pro2
  • Windows 10 Education, Enterprise, Pro23

1Windows Embedded Standard 7 is supported only in Application Compatibility Mode
2UEFI Supported
3Supports versions 1511 (November Update / Threshold 2), 1607 (Anniversary Update / Redstone), and 1703(Creators Update / Redstone 2).
3Versions 1709 (Fall Creators Update / Redstone 3) and 1803 (April 2018 Update / Redstone 4) are not supported.

Software Requirements:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
  • Visual C++ 2015 Update 3 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework, Visual C++ 2012 Update 4 and Visual C++ 2015 Update 3 is automatically installed when installing Dell Endpoint Security Suite Pro through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Pro. Failure to use the appropriate version may lead to product issues.
Note:

Operating Systems (32 and 64 bit):

  • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate1
  • Windows 8 Enterprise, Pro2
  • Windows 8.1 Update 0-1, Enterprise, Pro2
  • Windows 10 Education, Enterprise, Pro23

1Windows Embedded Standard 7 is supported only in Application Compatibility Mode
2UEFI Supported
3Supports versions 1511 (November Update / Threshold 2), 1607 (Anniversary Update / Redstone).
3Versions 1703 (Creators Update / Redstone 2), 1709 (Fall Creators Update / Redstone 3), and 1803 (April 2018 Update / Redstone 4)are not supported.

Software Requirements:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
  • Visual C++ 2015 Update 3 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework, Visual C++ 2012 Update 4 and Visual C++ 2015 Update 3 is automatically installed when installing Dell Endpoint Security Suite Pro through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Pro. Failure to use the appropriate version may lead to product issues.
Note:

Operating Systems (32 and 64 bit):

  • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate1
  • Windows 8 Enterprise, Pro2
  • Windows 8.1 Update 0-1, Enterprise, Pro2
  • Windows 10 Education, Enterprise, Pro23

1Windows Embedded Standard 7 is supported only in Application Compatibility Mode
2UEFI Supported
3Supports versions 1511 (November Update / Threshold 2), 1607 (Anniversary Update / Redstone).
3Versions 1703 (Creators Update / Redstone 2), 1709 (Fall Creators Update / Redstone 3), and 1803 (April 2018 Update / Redstone 4)are not supported.

Software Requirements:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework, Visual C++ 2012 Update 4 is automatically installed when installing Dell Endpoint Security Suite Pro through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Pro. Failure to use the appropriate version may lead to product issues.
  • Microsoft .NET Framework 4.5.2 (or later)
Note:

Operating Systems (32 and 64 bit):

  • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate1
  • Windows 8 Enterprise, Pro2
  • Windows 8.1 Update 0-1, Enterprise, Pro2
  • Windows 10 Education, Enterprise, Pro23

1Windows Embedded Standard 7 is supported only in Application Compatibility Mode
2UEFI Supported
3Supports versions 1511 (November Update / Threshold 2).
3Versions 1607 (Anniversary Update / Redstone), 1703 (Creators Update / Redstone 2), 1709 (Fall Creators Update / Redstone 3), and 1803 (April 2018 Update / Redstone 4) are not supported.

Software Requirements:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework, Visual C++ 2012 Update 4 is automatically installed when installing Dell Endpoint Security Suite Pro through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Pro. Failure to use the appropriate version may lead to product issues.
  • Microsoft .NET Framework 4.5.2 (or later)
Note:

Operating Systems (32 and 64 bit):

  • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate1
  • Windows 8 Enterprise, Pro2
  • Windows 8.1 Update 0-1, Enterprise, Pro2
  • Windows 10 Education, Enterprise, Pro23

1Windows Embedded Standard 7 is supported only in Application Compatibility Mode
2UEFI Supported
3Versions 1511 (November Update / Threshold 2), 1607 (Anniversary Update / Redstone), 1703 (Creators Update / Redstone 2), 1709 (Fall Creators Update / Redstone 3), and 1803 (April 2018 Update / Redstone 4) are not supported.

Software Requirements:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 4 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework, Visual C++ 2012 Update 4 is automatically installed when installing Dell Endpoint Security Suite Pro through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Pro. Failure to use the appropriate version may lead to product issues.
  • The full version of Microsoft .NET Framework 4.0 or later.
Note:

Operating Systems (32 and 64 bit):

  • Windows 7 SP0-SP1, Enterprise, Professional, Ultimate1
  • Windows 8 Enterprise, Pro2
  • Windows 8.1 Update 0-1, Enterprise, Pro2

1Windows Embedded Standard 7 is supported only in Application Compatibility Mode
2UEFI Supported

Software Requirements:

  • Dell Client Security Framework (EMAgent.exe)
  • Visual C++ 2012 Update 3 or later Redistributable Package (x86 and x64)
Note:
  • Dell Client Security Framework, Visual C++ 2012 Update 3 is automatically installed when installing Dell Endpoint Security Suite Pro through the installation wizard.
  • Only use the version of Dell Client Security Framework that is packaged with Dell Endpoint Security Suite Pro. Failure to use the appropriate version may lead to product issues.
  • The full version of Microsoft .NET Framework 3.5 or later.
Note:

For support, US-based customers may contact Dell Data Security ProSupport at 877.459.7304, Option 1, Ext. 4310039, or via the Chat Portal. To contact support outside the US, reference ProSupport’s International Contact Numbers. For additional insights and resources, visit the Dell Security Community Forum.


Код статьи: SLN295666

Дата последнего изменения: 06/26/2018 04:37 PM


Оцените эту статью

Точно
Функционально
Просто понять
Помогла ли вам эта статья?
Да Нет
Отправьте нам свое мнение
Комментарии не должны содержать следующие специальные символы: <>()\
К сожалению, наша система обратной связи в настоящее время не работает. Повторите попытку позже.

Благодарим вас за отзыв.