Dell Data Protection Protected Workspace Software and Hardware Prerequisites

Dell Data Protection Protected Workspace Software and Hardware Prerequisites


Note: As of January 2018, Dell Data Protection | Protected Workspace has reached EOS and this article is no longer updated by Dell. For more information reference End of Life / End of Support Policy for Dell Data Security. For support on Dell Data Protection | Protected Workspace, reference How do I get Support For Dell Data Protection Protected Workspace.

This Article contains information regarding hardware and software prerequisites for Dell Data Protection | Protected Workspace versions 5.1 and 6.1.3


Affected Products:

Dell Data Protection | Protected Workspace




table.MsoNormalTable {line-height:107%; font-size:11.0pt; font-family:"Calibri",sans-serif; }

Hardware Prerequisites

  • Intel Core 2 Duo or better processor
  • 1 GB RAM
  • 150 MB of free disk space

Software Prerequisites

The following Microsoft updates are required:

Note: These Microsoft KBs are installed as part of the DDP|PW installer, when the EXE installer is used.

Supported Operating Systems

Windows XP - 32-bit (requires Service Pack 3)

Windows 7 - 32 and 64-bit

Windows 8.1 - 32 and 64-bit (Windows 8 is not supported)

Windows 10 - 32 and 64-bit – Sensor Only

Windows Server 2008 -– Sensor Only

Windows Server 2008 R2 – Sensor Only

Windows Server 2012 – Sensor Only

Windows Server 2012 R2 – Sensor Only

Note:
  • Windows 10 Fall Creators Update is not supported currently with the latest PW v6.2.7. Dell/Invincea are working on getting a supported build published.
  • Windows 10 Redstone 2 (Creator) is supported starting with v6.2.6.

Required connectivity

Support Software

Browsers

  • Internet Explorer 7-11
  • Mozilla Firefox 32-bit 24-43
  • Mozilla Firefox 32-bit ESR 24, 31, and 38
  • Google Chrome 32-bit 27-47
  • Google Chrone 64-bit 37-47

Browser Plug-ins

  • ActiveIdentity for CAC Support
  • Adobe Flash 11+
  • Apple Quick TIme 7+
  • ATT Connect
  • AVG Toolbar
  • Bing Search for IE
  • Dell Data Protection | Security Tools Authentication
  • Facebook Video Calling
  • FileOpen for Adobe Reader/Acrobat
  • Ghostery
  • Google Hangouts
  • Google Maps for Chrome
  • Google Talk
  • Google Toolbar for IE
  • GoToMeeting
  • HP Network Printers
  • Java 6-8 (32 and 64-bit)
  • LastPass Password Manager
  • Lumension
  • Lync and Skype Click to Call
  • McAfee SiteAdvisor Enterprise 3.5
  • Microsoft Lync
  • Microsoft .NET Framework
  • Microsoft Silverlight (32 and 64-bit)
  • MS Cert Enroll
  • Norton Internet Security
  • Octoshape
  • PDF995
  • SafeNet
  • Trusteer
  • WebEx
  • Web of Trust
  • Yahoo Search for IE
  • Yahoo Toolbar

PDF Readers

  • Adobe Reader 9.X, XI, adn DC
  • Adobe Acrobat9, X, XI, and DC

Document Applications

  • Microsoft Word – 2010 and 2013, Office 365 (with Office 2013 apps only)
  • Microsoft Excel – 2010 and 2013, Office 365 (with Office 2013 apps only)
  • Microsoft PowerPoint – 2010 and 2013, Office 365 (with Office 2013 apps only)

Hardware Prerequisites

  • Intel i3 or better processor
  • 2 GB RAM
  • 150 MB of free disk space

Software Prerequisites

The following Microsoft updates are required:

Note: These Microsoft KBs are installed as part of the DDP|PW installer, when the EXE installer is used.

Supported Operating Systems

Windows 7 - 32 and 64-bit

Windows 8.1 - 32 and 64-bit (Windows 8 is not supported)

Windows 10 - 32 and 64-bit

Windows Server 2008 -– Detection Only

Windows Server 2008 R2 – Detection Only

Windows Server 2012 – Detection Only

Windows Server 2012 R2 – Detection Only

Note:
  • Windows 10 Fall Creators Update is not supported currently with the latest PW v6.2.7. Dell/Invincea are working on getting a supported build published.
  • Windows 10 Redstone 2 (Creator) is supported starting with v6.2.6.

Required connectivity

Support Software

Browsers

  • Internet Explorer 7-11
  • Mozilla Firefox 32-bit 24-46
  • Mozilla Firefox 32-bit ESR 24, 31, 38, and 45
  • Google Chrome 32-bit 27-50
  • Google Chrone 64-bit 37-50

Browser Plug-ins

  • ActiveIdentity for CAC Support
  • Adobe Flash 11+
  • Apple Quick TIme 7+
  • ATT Connect
  • AVG Toolbar
  • Bing Search for IE
  • Dell Data Protection | Security Tools Authentication
  • Facebook Video Calling
  • FileOpen for Adobe Reader/Acrobat
  • Ghostery
  • Google Hangouts
  • Google Maps for Chrome
  • Google Talk
  • Google Toolbar for IE
  • GoToMeeting
  • HP Network Printers
  • Java 6-8 (32 and 64-bit)
  • LastPass Password Manager
  • Lumension
  • Lync and Skype Click to Call
  • McAfee SiteAdvisor Enterprise 3.5
  • Microsoft Lync
  • Microsoft .NET Framework
  • Microsoft Silverlight (32 and 64-bit)
  • MS Cert Enroll
  • Norton Internet Security
  • Octoshape
  • PDF995
  • SafeNet
  • Trusteer
  • WebEx
  • Web of Trust
  • Yahoo Search for IE
  • Yahoo Toolbar

PDF Readers

  • Adobe Reader 9.X, XI, adn DC
  • Adobe Acrobat9, X, XI, and DC

Document Applications

  • Microsoft Word – 2010 and 2013, Office 365 (with Office 2013 apps only)
  • Microsoft Excel – 2010 and 2013, Office 365 (with Office 2013 apps only)
  • Microsoft PowerPoint – 2010 and 2013, Office 365 (with Office 2013 apps only)


Article ID: SLN302047

Last Date Modified: 09/14/2019 07:40 AM


Rate this article

Accurate
Useful
Easy to understand
Was this article helpful?
Yes No
Send us feedback
Comments cannot contain these special characters: <>()\
Sorry, our feedback system is currently down. Please try again later.

Thank you for your feedback.