How to Configure Switchport Modes on Dell EMC Networking N Series Switches


How to Configure Switchport Modes on Dell EMC Networking N Series Switches





This article discusses the Layer 2 switchport modes available and how to configure them on a Dell Networking N Series Switch.



Overview

  1. What modes are available
  2. Options on How to Configure Switchport Mode Access
  3. Options on How to Configure Switchport Mode Trunk
  4. Options on How to Configure Switchport Mode General

What Modes are Available

You can configure each port on a Dell Networking N1100, N1500, N2000, N2100, N3000 N3100 and N4000 series switches to be in one of the following switchport Layer 2 modes.
  • Access - Access ports are intended to connect end-stations to the system, especially when the end-stations are incapable of generating VLAN tags. Access ports support a single VLAN (the PVID). Packets received untagged are processed as if they are tagged with the access port PVID. Packets received that are tagged with the PVID are also processed. Packets received that are tagged with a VLAN other that the PVID are dropped. If the VLAN associated with an access port is deleted, the PVID of the access port is set to VLAN 1. VLAN 1 may not be deleted.
  • Trunk - Trunk-mode ports are intended for switch-to-switch links. Trunk ports can receive both tagged an untagged packets. Tagged packets received on a trunk port are forwarded on the VLAN contained in the tag if the trunk port is a member of the VLAN. Untagged packets received on a trunk port are forwarded on the native VLAN. Packets received on another interface belonging to the native VLAN are transmitted untagged on a trunk port.
  • General - General ports can act like access or trunk ports or a hybrid of both. When a port is in General mode, all VLAN features are configurable. When ingress filtering is on, the frame is dropped if the port is not a member of the VLAN identified by the VLAN ID in the tag. If ingress filtering is off, all tagged frames are forwarded. The port decides whether to forward or drop the frame when the port receives the frame.



Switchport Mode Behavior

Mode VLAN Membership Frames Accepted Frames Sent Ingress Filtering
Access One VLAN Untagged/Tagged Untagged Always On
Trunk All VLANs that exist in the system (default) Untagged/Tagged Tagged and Untagged Always On
General As many as desired Tagged or Untagged Tagged or Untagged On or Off

VLAN Tagging

Dell Networking N Series switches support IEEE 802.1Q tagging. Ethernet frames on a tagged VLAN Have a 4-byte VLAN tag in the header. VLAN tagging is required when a VLAN spans multiple switches, which is why trunk ports transmit and receive only tagged frames.
Note: A stack of switches behaves as a single switch, so VLAN tagging is not required for packets traversing different stack members.


Options on How to Configure Switchport Mode Access


Configuring a Port in Access Mode

Beginning in Privileged EXEC mode, use the following commands to configure an access mode VLAN interface and, optionally, assign the interface to a VLAN. When a port is in access mode, it can only be a member of one VLAN and will accept tagged packets with the access VLAN ID or untagged packets. Untagged packets are treated as belonging to the access VLAN. Packets received with a VLAN ID other than the access VLAN ID are discarded. When you configure an interface as an access mode port, the interface is automatically made a member of VLAN 1 and removed from all other VLAN memberships. you can configure each interface separately, or you can configure a range of interfaces with the same settings.



Command Parameters
Dell# configure Enter configuration mode.
Dell(config)# interface gi 1/0/1 Enter a specific interface. This could be a single physical interface, a range of ports or a port channel interface.
Dell(config-if-Gi1/0/1)# switchport mode access Set switchport mode to access. Dell N Series switches are in default switchport mode access out of the box.
Dell(config-if-Gi1/0/1)# switchport access vlan 100 Set the interface as a member of the specified VLAN. By default, access mode ports are members of VLAN 1.
Dell(config-if-Gi1/0/1)# end Leave interface configuration mode and go back to Privilege EXEC mode
Dell# show interfaces switchport gi 1/0/1 Display information on the port to verify the switchport mode configuration.


Example of show interface switchport output:
Dell# show interfaces switchport gi1/0/1

Port: Gi1/0/1
VLAN Membership Mode: Access Mode
Access Mode VLAN: 100
General Mode PVID: 1 (default)
General Mode Ingress Filtering: Enabled
General Mode Acceptable Frame Type: Admit All
General Mode Dynamically Added VLANs:
General Mode Untagged VLANs: 1
General Mode Tagged VLANs: 50,100
General Mode Forbidden VLANs:
Trunking Mode Native VLAN: 1 (default)
Trunking Mode Native VLAN Tagging: Disabled
Trunking Mode VLANs Enabled: All
Private VLAN Host Association: none
Private VLAN Mapping:
Private VLAN Operational Bindings:
Default Priority: 0
Protected: Disabled

Note: When viewing the output of the show interfaces switchport command be aware of the actual Membership Mode. That tells you what information below is actually relevant and in use. If the Membership mode is "Access Mode" then the general mode and trunking mode output is not relevant.

Options on How to Configure Switchport Mode Trunk

Configuring a Port in Trunk Mode


Beginning in Privileged EXEC mode, use the following commands to configure an interface as a layer 2 trunking interface, which connects two switches. Trunk mode ports support traffic tagged with different VLAN IDs. Untagged received traffic is switched in the native VLAN. A trunk port is automatically configured as a member of all VLANs. You can remove them from membership in specific VLANs. By default, the native VLAN for a trunk port is VLAN 1.


Command Parameters
Dell# configure Enter configuration mode.
Dell(config)# interface gi 1/0/1 Enter a specific interface. This could be a single physical interface, a range of ports or a port channel interface.
Dell(config-if-Gi1/0/1)# switchport mode trunk Set the switchport mode to trunk.
Dell(config-if-Gi1/0/1)# switchport trunk allowed vlan all By default trunk mode allows all vlans. This command is helpful when you need to return the trunk configuration back to default.
Dell(config-if-Gi1/0/1)# switchport trunk allowed vlan add 50,100 This adds VLANs 50 and 100 to the VLAN allowed list. Only the VLANs on the list will allowed to passed tagged frames.
Dell(config-if-Gi1/0/1)# switchport trunk allowed vlan remove 50,100 Removes the listed VLANs from the allowed list.
Dell(config-if-Gi1/0/1)# switchport trunk allowed vlan except 50,100 Allows all VLANs other than those listed.
Dell(config-if-Gi1/0/1)# switchport trunk native vlan-id 50 This sets the untagged VLAN for the trunk port. Untagged packets received on this interface are switched in the native VLAN. Transmitted packets in this VLAN are sent untagged.
Dell(config-if-Gi1/0/1)# no switchport mode This will default the switchport mode (default is access mode). Removing trunk mode.
Dell(config-if-Gi1/0/1)# end Leave interface configuration mode and go back to Privilege EXEC mode
Dell# show interfaces switchport gi 1/0/1 Display information on the port to verify the switchport mode configuration.


Example of show interface switchport output:
Dell# show interfaces switchport gi1/0/1
Port: Gi1/0/1

VLAN Membership Mode: Trunk Mode

Access Mode VLAN: 1 (default)

General Mode PVID: 1 (default)

General Mode Ingress Filtering: Enabled

General Mode Acceptable Frame Type: Admit All

General Mode Dynamically Added VLANs:

General Mode Untagged VLANs: 1

General Mode Tagged VLANs: 50,100

General Mode Forbidden VLANs:

Trunking Mode Native VLAN: 1 (default)

Trunking Mode Native VLAN Tagging: Disabled

Trunking Mode VLANs Enabled: All

Private VLAN Host Association: none

Private VLAN Mapping:

Private VLAN Operational Bindings:

Default Priority: 0

Protected: Disabled

Options on How to Configure Switchport Mode General


Configuring a Port in General Mode


Beginning in Privileged EXEC mode, use the following commands to configure an interface with full 802.1q support and configure the VLAN membership information for the interface. Except when noted as required (for example, when configuring MAB, Voice VLAN, or 802.1x), it is recommended that operators use either trunk or access mode.


Command Parameters
Dell# configure Enter configuration mode.
Dell(config)# interface gi 1/0/1 Enter a specific interface. This could be a single physical interface, a range of ports or a port channel interface.
Dell(config-if-Gi1/0/1)# switchport mode general Set the switchport mode to general.
Dell(config-if-Gi1/0/1)# switchport general allowed vlan add 50,100 tagged Sets the port to transmit tagged packets for the VLANs listed. If the command is used without specifying tagged or untagged, the default is untagged. Separate nonconsecutive VLAN IDs with a comma and no spaces. Use a hyphen to designate a range of IDs. (Range: 1-4093)
Dell(config-if-Gi1/0/1)# switchport general allowed vlan remove 50 Sets the list of VLAN IDs to remove.
Dell(config-if-Gi1/0/1)# switchport general pvid 50 (Optional) Set the port VLAN ID. Untagged traffic that enters the switch through this port is tagged with the PVID. The PVID assignment must be to an existing VLAN.
Dell(config-if-Gi1/0/1)# switchport general allowed vlan add 50 untagged Sets the port to pass untagged packets for the specified VLAN. This needs to match the VLAN set as the PVID.
Dell(config-if-Gi1/0/1)# switchport general acceptable-frame-type tagged-only (Optional) Specifies that the port will only accept tagged frames. Untagged frames are dropped at ingress.
Dell(config-if-Gi1/0/1)# switchport general ingress-filtering disable (Optional) Turn off ingress filtering so that all received tagged frames are forwarded whether or not the port is a member of the VLAN in the tag.
Dell(config-if-Gi1/0/1)# no switchport mode This will default the switchport mode (default is access mode). Removing general mode.
Dell(config-if-Gi1/0/1)# end Leave interface configuration mode and go back to Privilege EXEC mode.
Dell# show interfaces switchport gi 1/0/1 Display information on the port to verify the switchport mode configuration.



Example of show interfaces switchport command:

Dell# show interfaces switchport gi 1/0/1

Port: Gi1/0/1

VLAN Membership Mode: General Mode

Access Mode VLAN: 1 (default)

General Mode PVID: 50

General Mode Ingress Filtering: Enabled

General Mode Acceptable Frame Type: Admit All

General Mode Dynamically Added VLANs:

General Mode Untagged VLANs: 50

General Mode Tagged VLANs: 50,100

General Mode Forbidden VLANs:

Trunking Mode Native VLAN: 1 (default)

Trunking Mode Native VLAN Tagging: Disabled

Trunking Mode VLANs Enabled: All

Private VLAN Host Association: none

Private VLAN Mapping:

Private VLAN Operational Bindings:

Default Priority: 0

Protected: Disabled











文章 ID: HOW12148

上次修改日期: 08/18/2020 03:04 PM

為本文評分

準確
實用
易懂
這篇文章對您有用嗎?
0/3000 characters
請給予評分 (1 到 5 顆星)。
請給予評分 (1 到 5 顆星)。
請給予評分 (1 到 5 顆星)。
本文章是否有幫助?請選擇。
評語中不得包含下列特殊字元:<>()\
剩餘字元數。