ECS: GeoDrive: Error status returned when oplock request is denied

Summary: GeoDrive prompts "Error status returned when oplock request is denied" errors when uploading some files.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

GeoDrive generates messages like below:

Site=hostname  File=atmos.cpp  Line=16612  Revision=-v1.2.3.1
  Severity=WARNING  Category=0  Process=Server  Error=3221225698:3221225698 - Error status returned when oplock request is denied.
  Time=9/19/2018 2:11:27 PM 913 ms   Thread=480
File open error: d:\programdata\cifs-ecs data\e_drive\temp\123\l_b094.tmp.png

Cause

This is a client-related issue.

Resolution

This means that GeoDrive is doing a file upload, and it is trying to open the file and getting this error. This does not mean a GeoDrive issue, but a client issue.
 
This error means that some other process has an oplock on the file. GeoDrive wants to upload the file, so it tries opening it. This sends an oplock break to the client. The client should flush memory-resident data to disk and confirm that the oplock is gone, but it is not responding to the oplock break request. GeoDrive waits a while and never gets the oplock break so its open fails.
 
The problem is most likely in the client that is holding the oplock. Considering rebooting that client.

Additional Information

Affected Products

GeoDrive for Windows

Products

GeoDrive for Windows, ECS Appliance, ECS Appliance Hardware Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage
Article Properties
Article Number: 000039852
Article Type: Solution
Last Modified: 26 may 2025
Version:  5
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