PowerPath for Windows: Windows shows "harddisk??" in PowerPath
Summary: Windows shows "harddisk??" in PowerPath
Symptoms
Typically this has been seen when a migration activity from one set of disks to another set of disks has occurred. However there are other causes.
PowerPath for Windows displays "harddisk??" in the PowerPath GUI or in powermt display "dev=all."
The device is visible at the HBA level and also at the MPIO level.
Cause
It would appear that the Windows LDM is somehow compromised.
Resolution
Ensure that the file powermt.custom or powermt.custom.xml is removed (deleted) from the "c:\program files\EMC\powercommon" or "c:\program files\EMC\PowerPath" folders (depending on version of PowerPath) before carrying out any of the below options.
Option 1 - any of these steps may provide a resolution however if these do not then Option 2 or Option 3 must be carried out.
- Remove powermt.custom.xml file and Reboot.
- Scan for hardware changes in the device manager.
powermt check reconfig
Option 2
- Remove one or more suspect devices from visibility from the host.
- Open a command prompt (right click and Run as Administrator).:
Then run the following two commands in the command prompt:Set devmgr_show_nonpresent_devices=1
Start devmgmt.msc
This opens the device manager. - Select Menu item "View" "Show Hidden devices."
- Expand the disk section of the tree.
- Right click and uninstall all the grayed out disk devices (including all PowerPath devices).
- When complete reboot
- Make one or more devices visible to the host again.
- Scan for hardware changes in the device manager.
Option 3
- Remove all external devices from visibility from the host.
Note: If the host is Boot from SAN, then the boot device by necessity must be kept visible to the host down the primary boot path.
- Uninstall PowerPath and reboot.
- Open a command prompt (right click and Run as Administrator):
Then run the following two commands in the command prompt:Set devmgr_show_nonpresent_devices=1
Start devmgmt.msc
This opens the device manager - Select Menu item "View" "Show Hidden devices"
- Expand the disk section of the tree.
- Right click and uninstall all the grayed out disk devices (including all PowerPath devices).
- When complete reboot
- Make the devices visible to the host again.
- Install PowerPath and reboot.
Additional Information
If MPIO is not claiming devices properly (with no PowerPath installed), then an equivalent routine for MPIO is:
- Remove all external devices from visibility from the host.
- Disable/uninstall Microsoft feature MPIO and reboot
- Open a command prompt (right click and Run as Administrator):
Then run the following two commands in the command prompt:Set devmgr_show_nonpresent_devices=1
Start devmgmt.msc
This opens the device manager - Select Menu item "View" "Show Hidden devices"
- Expand the disk section of the tree.
- Right click and uninstall all the grayed out disk devices
- When complete reboot
- Make the devices visible to the host again.
- Scan for hardware changes in device manager
- Enable/install MPIO and reboot