Data Protection Advisor: Avamar Collection Requests Fail with "Failed to connect to database server"

Summary: Data Protection Advisor (DPA): Avamar Collection Requests Fail with the message "Failed to connect to database server."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Avamar data collection requests fail with the message:
 Failed to connect to database server
From Run in Debug dpaagent.log, the error looks like:
DBG1     4640.1508     20170417:154119    sodbc.pgsql.sodbc - sodbcOpen(): Failed to connect to database server. server= Avamar_server.FQDN, dbname=mcdb, user=viewuser, port=5555. Error was: Connection to database mcdb failed: could not translate host name "Avamar_server.FQDN" to address: Unknown host
 (-1)
DBG1     4640.1508     20170417:154119    sodbc.pgsql.connect - cpgsql():  Closing connection to postgres database. Server= Avamar_server.FQDN, DB=mcdb, Port=5555, User=viewuser
ERR      4640.1508     20170417:154119    agent.mod.avamar - jobmonitor(): failed to connect to server
The agent cannot translate the Avamar hostname Avamar_server.FQDN which is the Avamar server object in DPA Inventory.

Running nslookup from the agent host running the command Avamar_server.FQDN or Avamar server IP address fails, however the short name is resolved correctly.

Cause

DPA product is working as designed. This is a Domain Name System (DNS) issue.

Resolution

Correct the DNS.
 
In one instance, the issue was resolved after adding Avamar_server.FQDN and IP address in the hosts file on the remote agent.
 
For more information, contact the Dell Technical Support team.

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000052149
Article Type: Solution
Last Modified: 17 أبريل 2026
Version:  5
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