NVP-vProxy: Workflows intermittently fail to run "SYSTEM error Unable to bind socket to port 0 from connection port range 0-0:"

Resumen: NetWorker VMware Protection (NVP) backup workflows intermittently fail, reporting "unable to bind socket to port 0." This same type of error messaging appears for other workflows and processes on the NetWorker server. ...

Este artículo se aplica a Este artículo no se aplica a Este artículo no está vinculado a ningún producto específico. No se identifican todas las versiones del producto en este artículo.

Síntomas

The NetWorker VMware Protection (NVP) integration is configured with the vProxy Appliance.
The workflows intermittently fail to run in the environment with a socket bind error message.
The NetWorker Management Console (NMC) workflow messages and workflow log show:

MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Starting Protection Policy 'My_Policy' workflow 'My_WorkFlow'. 
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Starting action 'My_Policy/My_WorkFlow/My_BackupAction' with command: 'nsrvproxy_save -s My_NSR_Name -j 1568619 -L incr -p My_Policy -w My_WorkFlow -A My_BackupAction'. 
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow SYSTEM error Unable to bind socket to port 0 from connection port range 0-0: Cannot assign requested address 
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow SYSTEM error Unable to bind socket to port 0 from connection port range 0-0: Cannot assign requested address 
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Action 'My_Policy/My_WorkFlow/My_BackupAction's log will be in '/nsr/logs/policy/My_Policy/My_WorkFlow/My_BackupAction_1568635.raw'. 
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Action 'My_Policy/My_WorkFlow/My_BackupAction' failed. 
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow SYSTEM error Unable to bind socket to port 0 from connection port range 0-0: Cannot assign requested address 
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow SYSTEM error Unable to bind socket to port 0 from connection port range 0-0: Cannot assign requested address 
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Action 'My_Policy/My_WorkFlow/My_BackupAction log '/nsr/logs/policy/My_Policy/My_WorkFlow/My_BackupAction_1568635.raw' is empty. 
MM/DD/YYYY HH:MM:SS My_NSR_Name nsrworkflow NSR notice Workflow 'My_Policy/My_WorkFlow' failed.
The NetWorker daemon log shows similar bind socket error messages for other NetWorker processes in the environment.
 
Linux: /nsr/logs/daemon.raw
Windows: [INSTALL_DRIVE]:\Program Files\EMC NetWorker\nsr\logs\daemon.raw

Causa

The NetWorker Server Operating System does not have any open sockets available for the NetWorker processes.

Resolución

See the NetWorker kernel parameter requirements and TCP buffers sections of the NetWorker Performance Optimization and Planning Guidehttps://www.dell.com/support/product-details/product/networker/docs

Productos afectados

NetWorker

Productos

NetWorker Family
Propiedades del artículo
Número del artículo: 000166369
Tipo de artículo: Solution
Última modificación: 25 jul 2025
Versión:  4
Encuentre respuestas a sus preguntas de otros usuarios de Dell
Servicios de soporte
Compruebe si el dispositivo está cubierto por los servicios de soporte.