AppSync : Échec de la mise à niveau d’AppSync lors de la mise à niveau d’AppSync 3.5 vers AppSync 3.7
Résumé: AppSync : Échec de la mise à niveau d’AppSync lors de la mise à niveau d’AppSync 3.5 vers AppSync 3.7
Cet article concerne
Cet article ne concerne pas
Cet article n’est associé à aucun produit spécifique.
Toutes les versions du produit ne sont pas identifiées dans cet article.
Symptômes
La mise à niveau vers AppSync 3.7 à partir de la version 3.5 nécessite hériter des autorisations qui ne sont rarement pas en place.
Le AppSync_setup.log affiche les erreurs liées aux autorisations suivantes, comme indiqué ci-dessous :
Command.run() : C :\Users\xxxxxx \AppData\Local\Temp\201906.tmp\executeScriptTmp0.bat :stdout [C :\Users\xxxxxxxxx\AppData\Local\Temp\I1533065539\Windows>icacls « C :\EMC\AppSync » /grant :r « Users »:(OI)(CI)F ]
command.run() : C :\Users\xxxxxx \AppData\Local\Temp\201906.tmp\executeScriptTmp0.bat :stderr [Users : Aucune correspondance n’a été effectuée entre les noms de compte et les ID de sécurité.]
Command.run() : C :\Users\xxxxxx\AppData\Local\Temp\201906.tmp\executeScriptTmp0.bat :stdout [0 fichiers traités avec succès ; Échec du traitement de 1 fichier]
command.run() : C :\Users\xxxxxx \AppData\Local\Temp\201906.tmp\executeScriptTmp0.bat :stderr [Users : Aucune correspondance n’a été effectuée entre les noms de compte et les ID de sécurité.]
Command.run() : C :\Users\xxxxxx\AppData\Local\Temp\201906.tmp\executeScriptTmp0.bat :stdout [0 fichiers traités avec succès ; Échec du traitement de 1 fichier]
Le AppSync_setup.log se trouve dans le dossier temp AppData des utilisateurs.
Si l’utilisateur connecté qui a effectué la mise à niveau était AdminX, le AppSync_setup.log se trouve dans C :\Users\AdminX\AppData\Local\Temp.
Le journal du serveur AppSync indique que la version est 3.5.
La version Programmes et fonctionnalités indiquera que la version est 3.7.
Si l’utilisateur connecté qui a effectué la mise à niveau était AdminX, le AppSync_setup.log se trouve dans C :\Users\AdminX\AppData\Local\Temp.
Le journal du serveur AppSync indique que la version est 3.5.
La version Programmes et fonctionnalités indiquera que la version est 3.7.
Cause
La mise à niveau de la base de données AppSync échoue en raison d’un problème d’autorisation.
Résolution
Une fois que la version précédente ( AppSync 3.5) est disponible, ouvrez une invite DOS en mode administrateur et exécutez la commande ci-dessous :
Il doit renvoyer :
Ensuite, la mise à niveau vers la version 3.7 sera réussie.
icacls « C :\EMC\AppSync » /grant :r « Users »:(OI)(CI)F
Il doit renvoyer :
Traitement réussi de 1 dossiers ; Échec du traitement de 0 fichier
Ensuite, la mise à niveau vers la version 3.7 sera réussie.
Produits concernés
AppSyncProduits
AppSyncPropriétés de l’article
Numéro d’article: 000167509
Type d’article: Solution
Dernière modification: 18 Sep 2025
Version: 4
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.