RecoverPoint for VMs: Upgrade from 5.3.0.x or 5.3.1.0 may stop responding at 11% or 84%

Summary: Upgrade from RecoverPoint for VMs 5.3.0.x or 5.3.1.0 may fail with possible error: "Error: Upgrade had failed. If upgrade keeps failing, contact customer support. vRPA is not up"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

There are several different possible symptoms from the same root cause:

Symptom 1:
The Debian package upgrade did not go through even though installation logs say it was successful.

Symptom 2:
Tomcat service did not come up after reboot.

Symptom 3:
One or more of the following messages are seen in clusterLogic logs in RPA1 or RPA2:

ERROR - Failed to connect to vRPA with IP <IP>.
com.sun.xml.ws.client.ClientTransportException: HTTP transport error: java.net.ConnectException: Connection refused (Connection refused)
ERROR - UpgradeRemoteRPATask :Task failed: Upgrading vRPA number <RPA NUMBER>.
com.emc.recoverpoint.utils.javainfra.status.tasks.exception.TaskFailedException: vRPA <IP> is not up.

Symptom 4:
The following messages are seen on the UI:

The error seen in UI is "Error: Upgrade had failed. If upgrade keeps failing, contact customer support. vRPA <IP> is not up"

 

Cause

When the RPA is being upgraded, the Debian packages (.deb files) are installed and a reboot is performed.
The package installation runs in the background which may get aborted by the reboot in the next step of upgrade.
Because the installer is killed before completion, the tomcat8.service may not be available in the systemd directory, resulting in failure to restart tomcat8 and causing the RPA to be unreachable.

 

Resolution

Preventative workaround:
Login as admin user to each RPA before the upgrade and run the following signed script ([2] Setup -> [8] Advanced options -> [4] Run script

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Resolution:
This issue is resolved in RecoverPoint 5.3 SP1 Patch 1 and later code versions.
Upgrade from 5.3 SP1 P1 and later should prevent the issue from occurring.

 

Additional Information

Note:
For more information, consult Jira defect number RP-31718. Jira access is only available to authorized Customer Service Representatives.

 

Products

RecoverPoint for Virtual Machines
Article Properties
Article Number: 000182751
Article Type: Solution
Last Modified: 20 Jan 2025
Version:  5
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