Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

External Monitors That Are Connected to Dell Universal Docks D6000 May Flicker, Have No Video, or Video Artifacting That Are Docked with Intel 11th Generation Computers.

Summary: This article provides information about how to resolve no video, video artifact, or video flicker issue on external monitors when an Intel 11th generation Dell computer is connected to the Dell Universal Dock D6000. ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Select Dell laptops with Intel 11th generation graphics cards may exhibit a no video, video artifacts, or video flicker issue on external monitors when the laptop and external monitor is connected to a Dell Universal Dock D6000. An explanation mark is shown in device manager on the D6000 dock (Figure 1).


Figure 1: – Bang (Exclamation mark) on Dell Universal Dock D6000.

The Dell D6000 docking station may be recognized but the external monitors display video artifacts, or constantly lose video (flicker). The computer internal LCD screen may also appear to have issues during the initialization of the dock or external displays.

Affected computers

  • Latitude 13-5320
  • Latitude 13-7320
  • Latitude 13-7320 Detachable
  • Latitude 14-5420
  • Latitude 14-7420
  • Latitude 14-9420
  • Latitude 15-5520
  • Latitude 15-7520
  • Latitude 15-9520
  • Precision 3560
  • XPS 13-9310
  • XPS 13-9310 2-in-1

Cause

This issue is seen after updating to the latest Intel Graphics driver for the computer and the DisplayLink Driver v9.3.3324.0 or v10.1.2665.0 are installed on the computer. This issue has been reported with the following Intel graphics card drivers:

  • ​Intel Iris Xe Graphics Driver 27.20.100.9168
  • Intel Iris Xe Graphics Driver 27.20.100.9466
  • Intel UHD Graphics Driver 27.20.100.9415

Resolution

To resolve this issue, follow the instructions below to download and install the latest DisplayLink driver for the Dell D6000 docking station.

Download and install the latest DisplayLink driver

Before you begin, disconnect the Dell D6000 docking station from the Dell laptop.

  1. Browse to the Dell Drivers & Downloads website.
  2. Identify your Dell D6000 docking station.
    • Enter the Service Tag, Express Service Code, or the Serial number of the Dell product and click Search.
    • Or, click Browse all products, Electronics & Accessories, PC & Tablet Accessories to manually select the Dell D6000 docking station from the catalog.
  3. Select the Operating System that is installed on the computer.
  4. Under Category, select Docks/Stands.
  5. Locate the latest DisplayLink Dock Driver (version 10.1.2814.0 or newer). Click Download and save the file to the computer.
  6. Using File Explorer (also known as Windows Explorer), browse to the location where the downloaded file was saved.
  7. Double-click the DisplayLink driver installation file that you downloaded and follow the on-screen instructions to complete the installation process.
  8. After the driver installation is complete, restart the computer.
  9. Connect the monitor and other devices to the Dell D6000 docking station.
  10. Connect the Dell D6000 docking station to the laptop.

Article Properties


Affected Product

Dell Universal Dock D6000, Latitude 5320, Latitude 7320, Latitude 7320 Detachable, Latitude 7420, Latitude 9420, Latitude 5520, Latitude 7520, Latitude 9520, Latitude 5420, Precision 3560, XPS 13 9310 2-in-1, XPS 13 9310

Last Published Date

16 Jul 2021

Version

22

Article Type

Solution