CloudIQ: Unable to request a code with the current Dell EMC Customer support credentials

Summary: The above error may occur when a CloudIQ Collector is being configured to an integrated gateway.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Customer is attempting to configure a CloudIQ Collector to an integrated gateway using the following procedure:
  1. Power on the CloudIQ Collector.
  2. Login to the CloudIQ Collector.
  3. Select Admin > Settings and the Integrated Gateway tab.
  4. Plug in the Dell EMC user account (email) and password (no special characters) and click on Start Provisioning.
  5. No proxy direct connection – leave off unless required.
  6. It then verifies the user account (email) and asks the customer to request an access code.
  7. Once the code is received the customer would then plug this in and select a site ID that is also verified.
  8. The integrated gateway (ISWID) is then created and the CIQ Collector is created (SWID) and placed under the gateway to be managed.
***The above procedure is failing at step 6 above and the customer receives the message "Unable to request a code with the current Dell EMC Customer support credentials" as noted in the screenshot below.


Collecting the Diagnostic file shows the following ERROR within the provisioning log (hostmnt_log > var > log > esrs).

"PKIX path building failed"

 
 

Cause

Customer is utilizing an SSL interceptor or transparent proxy within their network.  This will substitute the certificate authority and crack the inscription causing the issue.

Resolution

Options:
  1. Customer can enter in an exception or exclusion for the SSL interceptor (or transparent proxy) application to continue using the CloudIQ Collector’s eVE configuration.
  2. Customer can install a new centralized gateway and configure the CloudIQ Collector to it.  The centralized gateway being used would also need an exception or exclusion for the SSL interceptor (or transparent proxy) application.  This would need to be addressed by the customer and/or the customer’s network team in the same manner as in option 1 above.

Additional Information

Exceptions/exclusions must be made using a third party tool or the SSL interceptor or proxy application outside of Secure Connect Gateway (SCG).

Customers may exclude *.emc.com to cover all the domains or list each separately.

● The local system must be able to connect to the following Enterprise servers through ports 443 and 8443:

  • esrs3-core.emc.com
  • esrs3-coredr.emc.com

● The local system must be able to connect to the following Global access servers through ports 443 and 8443:

  • esr3gduprd01.emc.com
  • esr3gduprd02.emc.com
  • esr3gduprd03.emc.com
  • esr3gduprd04.emc.com
  • esr3gduprd05.emc.com
  • esr3gduprd06.emc.com
  • esr3ghoprd01.emc.com
  • esr3ghoprd02.emc.com
  • esr3ghoprd03.emc.com
  • esr3ghoprd04.emc.com
  • esr3ghoprd05.emc.com
  • esr3ghoprd06.emc.com
  • esr3gscprd01.emc.com
  • esr3gscprd02.emc.com
  • esr3gscprd03.emc.com
  • esr3gscprd04.emc.com
  • esr3gscprd05.emc.com
  • esr3gscprd06.emc.com
  • esr3gckprd01.emc.com
  • esr3gckprd02.emc.com
  • esr3gckprd03.emc.com
  • esr3gckprd04.emc.com
  • esr3gckprd05.emc.com
  • esr3gckprd06.emc.com
  • esr3gckprd07.emc.com
  • esr3gckprd08.emc.com
  • esr3gckprd09.emc.com
  • esr3gckprd10.emc.com
  • esr3gckprd11.emc.com
  • esr3gckprd12.emc.com
  • esr3gspprd01.emc.com
  • esr3gspprd02.emc.com
  • esr3gspprd03.emc.com
  • esr3gspprd04.emc.com
  • esr3gspprd05.emc.com
  • esr3gspprd06.emc.com
  • support.emc.com

Affected Products

CloudIQ

Products

CloudIQ
Article Properties
Article Number: 000202819
Article Type: Solution
Last Modified: 21 Feb 2023
Version:  7
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