NetWorker: Error Appears in Administration "Message bus unable to open socket connection"

Summary: Error message displays when viewing workflow details in NetWorker Administration "Message bus unable to open socket connection to host "Networkerserver_hostname" on port 5672: A socket error occurred." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker Management Console (NMC) server is installed on a stand-alone system separate from the NetWorker server.

The NMC monitoring window shows all policies as "Never Run"; however, backup and clone jobs are completing as scheduled.

The following error appears in the NMC when trying to open workflow or action properties:

Message bus unable to open socket connection to host "Networkerserver_hostname" on port 5671: a socket error occurred.

Port 5671 is listening on the NetWorker server. Port 5671 is the SSL port used by the message queue adapter process.

Linux: netstat -apno | grep 5671

Windows: netstat -ano | findstr 5671

The NMC server fails to connect to the NetWorker server over port 5671.

Linux: curl -v NetWorker_ServerName:5671

Windows (PowerShell): tnc NetWorker_ServerName -port 5671

 

Cause

Port 5671 is the SSL port used by the message queue adapter used to communicate between the NetWorker Management Console (NMC) server and NetWorker server. See: NetWorker Processes and Ports

This appears under the following scenarios:

  • The NetWorker server OS firewall is blocking port 5671
  • There is a network firewall between the NetWorker Management Console (NMC) or NetWorker Web User Interface (NWUI) server and the NetWorker server.

 

Resolution

  1. On the NetWorker server, create an inbound firewall rule to allow traffic for port 5671.
  2. On the NMC server, create an outbound rule to allow traffic from port 5671.

See operating system vendor instructions for creating firewall rules; the system or security administrator must make these changes. Once changes are applied to the operating system firewall, confirm if port 5671 connectivity succeeds between the NetWorker server and NMC server. If the connection still fails, ensure that a network firewall is not blocking the communication.

Additional Information

Affected Products

NetWorker

Products

NetWorker Family, NetWorker Series
Article Properties
Article Number: 000210569
Article Type: Solution
Last Modified: 17 May 2026
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.