PowerScale: macOS Ventura Clients Experiencing Issues Accessing Files Over SMB
Summary: Clients recently upgraded to macOS Ventura may periodically experience issues when trying to access or create files, particularly Microsoft Excel files, Rich Text (RTF), and PDFs.
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Not all product versions are identified in this article.
Symptoms
Apple has identified an issue with client machines that recently upgraded to macOS Ventura. They may experience unexpected behaviors when attempting to create or access files over SMB protocol. In some instances of the field, it was observed that a client goes to a share and finds all files in a Read-Only state when they had sufficient privileges to do more.
In some instances, permissions at the share-level must be adjusted further as the client operating system blocks the open operation over SMB protocol.
In some instances, permissions at the share-level must be adjusted further as the client operating system blocks the open operation over SMB protocol.
Cause
A code issue on the client operating system was identified that Apple has recently addressed.
Resolution
The permanent fix is for macOS Ventura clients to upgrade to version 13.3. When this cannot be done in a timely fashion, Apple has provided the following workaround. This must be performed on the impacted client and requires a remount.
Workaround:
Workaround:
- Unmount the share on the client.
- Create the following file on the client, adding the parameters as follows:
sudo touch /etc/nsmb.conf echo "[default]" | sudo tee -a /etc/nsmb.conf echo "file_ids_off=yes" | sudo tee -a /etc/nsmb.conf
- Mount the share on the client.
Affected Products
PowerScale OneFSArticle Properties
Article Number: 000211850
Article Type: Solution
Last Modified: 07 Nov 2025
Version: 5
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