PowerScale: Isilon: CloudIQ Health Score Impacted by False/Resolved Alerts

Summary: PowerScale: Isilon: Customers may report CloudIQ Health Scores impacted by alerts which have been resolved and cleared.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A cluster’s CloudIQ Health Score may be less than 100 with “Health Issues” reporting stale or resolved alerts.

When performing a health check on the cluster, the alerts listed in “Health Issues” in CloudIQ may be historical and resolved.

Cause

CloudIQ can calculate a Health Score based on the results of an IOCA healthcheck using “isi healthcheck evaluations run ioca.” This can occur in instances where updated IOCA health results are not received and processed in daily metrics.

Subsequent recurring Health Score updates reported in CloudIQ can utilize the most recently performed IOCA healthcheck to calculate the current score.

Resolution

  • Confirm which alerts are being reported in CloudIQ in the “Health Issues” section.
  • On the cluster, confirm whether the conditions for these alerts are resolved, and the alert has been cleared.
    • If issues which can impact a health score are present, resolve all issues/alerts and proceed to performing an IOCA healthcheck.
  • Use the command “isi healthcheck evaluations run ioca” to perform an IOCA healthcheck and confirm that all alerts pass.
  • Allow up to 24 hours for CloudIQ to update and confirm that the CloudIQ Health Score alerts accurately reflect any active alerts on the cluster.

Additional Information

Affected Products

Isilon, PowerScale OneFS
Article Properties
Article Number: 000215940
Article Type: Solution
Last Modified: 17 Oct 2023
Version:  3
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