IDPA: 2.7.4 upgrade fails at 56% hypervisor/ESXi sub-component progress due to VIB dependency failure
Summary: This article describes steps required to resolve an 2.7.4 upgrade failure caused by a software dependency on the ESXi hypervisor component.
Ez a cikk a következő(k)re vonatkozik:
Ez a cikk nem vonatkozik a következő(k)re:
Ez a cikk nem kapcsolódik egyetlen konkrét termékhez sem.
Ez a cikk nem azonosítja az összes termékverziót.
Symptoms
An upgrade to IDPA version 2.7.4 may fail at 56% sub-component progress (Or approximately 82% overall progress) on the "Hypervisor and Server Firmware" workflow. The workflow panel may report an "Failed to install upgrade packages" error.
Upgrade Workflow Errors

Hypervisor and Server Firmware Panel Messages
Upgrading Hypervisor. This may take around 15 minutes Installing upgrade packages on Hypervisor Failed to install upgrade packages Failed to upgrade Hypervisor Server Creating log bundle. Created log bundle.
Log Messages and Patterns
The upgrade logs (/data01/tmp/patch/logs/esxi_logs.log) may report a dependency error.
21/07/23 12:11:25 main() Executing install packages command: esxcli software profile update --depot=https://192.168.100.100:9443/dataprotection-upgrade/esxi_upgrade --profile=IDPA-14G-ESXi-7.0.3-041 --no-sig-check
21/07/23 12:11:25 main() Install packages command result: {'output': [u'Name Vendor Acceptance Level Creation Time Modification Time', u'----------------------- -------- ---------------- ------------------- -------------------', u'IDPA-14G-ESXi-7.0.3-041 Dell-EMC PartnerSupported 2022-07-06T14:41:16 2022-09-10T03:41:07', u'Status: 0'], 'returnCode': 0}
21/07/23 12:11:36 run() Parsing returnCode, output: ['', '[DependencyError]\r\n VIB DEL_bootbank_racadm_9.4.0.ESXi670-3749 requires esx-version << 7.0, but the requirement cannot be satisfied within the ImageProfile.\r\n Please refer to the log file for more details.', 'Status: 1']
21/07/23 12:11:36 run_cmd_esxi_output() Command: esxcli software profile update --depot=https://192.168.100.100:9443/dataprotection-upgrade/esxi_upgrade --profile=IDPA-14G-ESXi-7.0.3-041 --no-sig-check
21/07/23 12:11:36 run_cmd_esxi_output() [DependencyError]
21/07/23 12:11:36 run_cmd_esxi_output() VIB DEL_bootbank_racadm_9.4.0.ESXi670-3749 requires esx-version << 7.0, but the requirement cannot be satisfied within the ImageProfile.
21/07/23 12:11:36 run_cmd_esxi_output() Please refer to the log file for more details.
21/07/23 12:11:36 run_cmd_esxi_output() Status: 1
21/07/23 12:11:36 main() exit code is: 1
21/07/23 12:11:36 main() Command output is: VIB DEL_bootbank_racadm_9.4.0.ESXi670-3749 requires esx-version << 7.0, but the requirement cannot be satisfied within the ImageProfile.
21/07/23 12:11:36 main() Failed to install packages.
Cause
An incompatible version of the iDRAC tools software package has been installed on the ESXi host. The iDRAC tools software package is an optional software component which provides extended functionality for managing the iDRAC out-of-band management platform.
Resolution
1. Open an SSH/PuTTY session to the ESXi host (hypervisor) as the "root" user
2. Confirm that the iDRAC tools software package (racadm) is installed
[root@dp4400-esx:~] esxcli software vib list | grep racadm racadm 9.4.0.ESXi670-3749 DEL PartnerSupported 2021-03-30
3. Remove the iDRAC tools software package
[root@backup-esx:~] esxcli software vib remove -n racadm Removal Result Message: Operation finished successfully. Reboot Required: false VIBs Installed: VIBs Removed: DEL_bootbank_racadm_9.4.0.ESXi670-3749 VIBs Skipped:
Additional Information
iDRAC Tools 9.4.0 and earlier versions are unsupported and will not allow install or upgrade to VMware ESXi 7.0
https://www.dell.com/support/kbdoc/en-us/000176821/idrac-tools-9-4-0-and-earlier-versions-are-unsupported-and-will-not-allow-install-or-upgrade-to-vmware-esxi-7-0?lang=en
https://www.dell.com/support/kbdoc/en-us/000176821/idrac-tools-9-4-0-and-earlier-versions-are-unsupported-and-will-not-allow-install-or-upgrade-to-vmware-esxi-7-0?lang=en
Érintett termékek
PowerProtect DP4400, PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, PowerProtect Data Protection Hardware, Integrated Data Protection Appliance SoftwareTermék tulajdonságai
Article Number: 000216067
Article Type: Solution
Utoljára módosítva: 14 szept. 2023
Version: 3
Választ kaphat kérdéseire más Dell-felhasználóktól
Támogatási szolgáltatások
Ellenőrizze, hogy a készüléke rendelkezik-e támogatási szolgáltatással.