PowerProtect Data Manager: NAS protection job fails with error message "ABNA0016:

Summary: Unable to complete the SNAPSHOT_AND_SLICE operation because the share path fileshare could not be mounted at fileshare." NAS protection jobs fail because file share cannot be mounted.

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Symptoms

For NAS protection job to perform "Snapshot and Slice" operation, NAS protection engine (NAS proxy) must be a mounted file share within its container. When a file share cannot be mounted, error messages similar to the following can be found in the log file for the failed job:
nasdm.2023-07-24.0.log.gz: 2023-07-23T20:25:11.834Z WARN [] [pool-45-thread-1] [00000000-0000-4000-a000-000000000000][][TASK_ID:a7b2f318790878cc][TRACE_ID:bc15102b73e03670;JOB_ID:bbf15c6d784953e2][] [c.e.d.e.n.s.CommonResourceService.getVendorSpecificErrorMessageOrErrorMessage(440)] -  It seems VendorSpecificErrorMessage empty or null, so setting ErrorMessage: 
 Unable to mount the share path /fileshare .
 
nasdm.2023-07-24.0.log.gz: 2023-07-23T20:25:11.834Z ERROR [] [pool-45-thread-1] [00000000-0000-4000-a000-000000000000][][TASK_ID:a7b2f318790878cc][TRACE_ID:bc15102b73e03670;JOB_ID:bbf15c6d784953e2][] [c.e.d.e.n.s.b.SnapshotSliceService.completeSessionFailure(301)] -  Error: SnapshotAndSlice, ErrorMessage NAS vProxy Engine nasproxy.yourcompany.com is unable to perform SnapshotAndSlice operation for nasShare fileshare. 

Error Details:
 TaskId: cbb90ba1-79a9-4ca4-bbf1-5c6d784953e2, JobId cbb90ba1-79a9-4ca4-bbf1-5c6d784953e2 
 NAS Backup is unsuccessful.  NAS agent error code 'ABNA0016'. 
 Unable to mount the share path /fileshare .
. 

nasdm.2023-07-24.0.log.gz: 2023-07-23T20:25:13.953Z ERROR [] [pool-45-thread-1] [00000000-0000-4000-a000-000000000000][ALERT:ABNA0016][TASK_ID:a7b2f318790878cc][TRACE_ID:bc15102b73e03670;JOB_ID:bbf15c6d784953e2][] [c.e.d.e.c.s.m.DefaultMessageResourceModifier.printAlertLog(143)] -  Date: Jul 24, 2023 04:25:13 AM; Summary: Unable to complete the SNAPSHOT_AND_SLICE operation because the share path /fileshare could not be mounted at /fileshare.; Details: PowerProtect Data Manager cannot mount a share on the defined path.; Recommended Action: To troubleshoot this issue: 
1) For CIFS, check the share credentials. 
2) For NFS, verify whether the share can be mounted and NAS protection engine has access to that share. 
3) For generic assets, cookie authorization is not supported. Generic assets only supports basic authentication.; Detail Summaries: null; Status: UNACKNOWLEDGED 

Cause

Mounting of a file share may fail due to multiple reasons. Some of the reasons are already mentioned in the error message above in the Symptoms above. There are additional causes that may result into above mentioned error messages. The following are some of them:
  • Name resolution not working on the NAS protection engine.
  • Network firewalls blocking traffic.
  • Usage of the same subnet for both IP addresses on the NAS protection engine, when VLAN configuration is in use. Sometimes this may end up assigning same IP address to both Ethernet's on the NAS protection engine.
  • Errors while creating a folder for mounting file share

Resolution

The following are some of the action items to rule out probable causes for the errors:
  1. Ensure that credentials are added to PowerProtect Data Manager for accessing NAS file shares have all the needed privileges and or permissions. More information about required permissions to process NAS protection could be found in the PowerProtect Data Manager Network Attached Storage User Guide.
  2. For CIFS file share, the NAS protection engine tries to mount file share first using CIFS V3 followed by V2 and V1. As a result, we can discount that the issue is related to the protocol itself since all three protocols are tried.
  3. Name resolution on the NAS protection engine must be checked especially if you find that jobs using FQDN in the file share path are failing and jobs with IP address in the path are succeeding without issue. To perform this check, log in to the NAS protection engine. Contact PowerProtect Data Manager support to have this check performed because credentials of the NAS protection engine are not available within PowerProtect Data Manager User Interface (PowerProtect Data Manager UI). 
  4. Using VMWARE vCenter UI, check to confirm if the NAS protection engine has the correct network addresses assigned.
  5. Confirm with network, security, and VMWARE teams to confirm correct network configuration is in place and required traffic is allowed at all levels (for example, VMWARE ESXi firewall, hardware or software firewalls, vSwitches or physical switches and so on). More information about ports in use and network traffic can be found in the PowerProtect Data Manager Security Configuration Guide.
  6. While deploying a NAS protection engine, see "Deploy a protection engine for NAS asset protection" section of the PowerProtect Data Manager NAS Attached Storage User Guide especially look for "Network" and "Network Configuration" points because they clarify which section is applicable to management traffic and which section is applicable to data traffic if there is VLANs usage. 
  7. Check free space on the NAS protection engine using "df -h" command. Sometimes if due to an issue in past data was not cleaned up from drives attached to NAS protection engine, it may result in one of the drives on the protection engine to fill up to the capacity causing "mkdir" command to fail while creating folders for mounting file shares.

Affected Products

PowerProtect Data Manager Appliance, PowerProtect Data Manager, PowerProtect Data Manager Essentials, PowerProtect Data Manager Software, PowerProtect DM5500
Article Properties
Article Number: 000216345
Article Type: Solution
Last Modified: 16 Jul 2025
Version:  3
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