Dell NativeEdge: Factory Reset Image fails to download from the NativeEdge Orchestrator

Summary: This article outlines the steps to take if the download of the Factory Reset Image fails in the NativeEdge Orchestrator.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When attempting to generate and download the Factory Reset Image, from the NativeEdge Orchestrator, the image download fails with the message :-
Image download failed:INTERNAL_SERVER_ERROR


Cause

It is possible that during the Factory Reset Image generation process that the service responsible can become overloaded and will restart.

Resolution

Workaround 1:

Wait for between 30 minutes to an hour and then to retry the Factory Reset Image download.

Workaround 2:

NativeEdge engineering recommends restarting the pod mist-ee-api-v2 if the workaround 1 has not succeeded. An example of this is the following:
kubectl -n hzp rollout restart deployment mist-ee-api-v2
Verify that the mist-ee-api-v2 pod has restarted:
kubectl get pod -n hzp  $(kubectl get pods -n hzp | grep api |awk '{print $1}')

NAME                              READY   STATUS    RESTARTS   AGE
mist-ee-api-v2-7564697644-ck2rf   2/2     Running   0          12s
(in this example above the user sees the age to be short as the deployment has been restarted.)

Retry the operation to download the Factory Reset Image.

If neither workarounds succeed contact Dell NativeEdge Support through a Service Request to get this issue resolved and quote this article number.

Affected Products

NativeEdge Solutions, NativeEdge
Article Properties
Article Number: 000216825
Article Type: Solution
Last Modified: 12 Mar 2024
Version:  3
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