[PPDM VMware] VM backup is failing with error code: ABV0022. "VDDK Error: 13: You do not have access rights to this file"
摘要: PPDM VM backup fails with the error "VDDK Error: 13: You do not have access rights to this file". Error code: ABV0022
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
PPDM VADP VM backup fails for one VM. The error code is: ABV0022. Below is the error logged in the 'vmdm.log'
Result: {
"sessionId" : "ddeddd9b-eabd-4b31-97f1-ba95d86f1ccb",
"state" : "Failure",
"logFile" : "/opt/emc/vmdirect/runtime/logs/vpod/BackupJobSessions-ddeddd9b-eabd-4b31-97f1-ba95d86f1ccb.log",
"error" : "Backup has FAILED. Unable to backup virtual disk \"Hard disk 1\". Unable to initialize Block Reader. Unable to open source VMDK '[DataStore1] vm01 /vm01.vmdk'. VDDK Error: 13: You do not have access rights to this file. (500)",
"proxyHostName" : "ppdm-proxy2.mylab.local",
"errorCode" : "ABV0022"
Backups of other VMs on the same esxi host where the failing VM resides work. The backups are being done using 'nbdssl' transport mode:
YYYY-MM-DDThh:mm:ss. DEBUG: [8be7c6997b53d431;92698b9f52cd437e] Opening VDDK connection to 'vm-500' @ 'esx01.mylab.local' using 'nbdssl' ..The vCenter user used by PPDM to perform the backups has sufficient permissions.
原因
PPDM proxy is unable to access the VM files to backup using 'nbdssl' transport mode. vSphere is refusing the access request.
解决方案
Since backups using 'nbdssl' is failing only for this VM, use 'hotadd' instead to perform the backup. PPDM will use hotadd transport mode, if it can locate a Protection Engine that has access to the datastore the VM is on. Review your configuration and deploy an external Protection Engine to the esx host that has access to this datastore to allow for 'hotadd' transport mode.
If backups must be performed using 'nbdssl', engage Vmware support to troubleshoot why 'nbdssl' access to this VMs snapshot is failing.
If backups must be performed using 'nbdssl', engage Vmware support to troubleshoot why 'nbdssl' access to this VMs snapshot is failing.
受影响的产品
PowerProtect Data Manager文章属性
文章编号: 000219169
文章类型: Solution
上次修改时间: 25 5月 2026
版本: 2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。