Dell NativeEdge : Le téléchargement à partir du catalogue échoue avec le message « Internal Server Error »

Résumé: Dans NativeEdge Orchestrator 3.0.0.0, le téléchargement à partir du catalogue peut échouer avec le message « Internal Server Error »

Cet article concerne Cet article ne concerne pas Cet article n’est associé à aucun produit spécifique. Toutes les versions du produit ne sont pas identifiées dans cet article.

Symptômes

Dans NativeEdge Orchestrator 3.0.0.0, une nouvelle fonctionnalité est introduite pour télécharger directement des blueprints et des plug-ins au sein de NativeEdge Orchestrator dans un environnement non isolé. Vous pouvez observer une « erreur interne du serveur » lorsque vous essayez de télécharger des plug-ins de plus grande taille. 

Erreur de serveur interne lors du téléchargement d’un plug-in volumineux

Si vous examinez les journaux réseau à l’aide de l’outil de développement du navigateur, vous pouvez voir le message « Erreur de serveur interne 500 »

Erreur 500 lors de l’affichage à partir de l’outil de développement du navigateur

Cause

Cela se produit lorsqu’un téléchargement prend plus de 30 secondes. Les journaux du back-end de stage génèrent l’erreur ci-dessous. 

message: 
"Requested URL: /plugins?title=Nativeedge%20Gcp%20Plugin&visibility=tenant&package_name=nativeedge-gcp-plugin&plugin_archive_url=https%3A%2F%2Fdownloads.dell.com%2FFOLDER12410532M%2F1%2Fnativeedge-gcp-plugin_1.10.10.0_J34CH.wgn ECONNABORTED timeout of 30000ms exceeded" 

Résolution

L’erreur « 500 internal server error » est une fausse alerte. Dans la plupart des cas, le fichier de plug-in est téléchargé avec succès. 

Les utilisateurs peuvent actualiser l’interface de « Download from Catalog ». Le plugin téléchargé s’affiche correctement.

Comment actualiser l’interface utilisateur du catalogue

Si la solution ci-dessus ne fonctionne pas, contactez le support Dell pour poursuivre le dépannage. 

Le correctif sera disponible dans la prochaine version de NativeEdge. 

Produits concernés

NativeEdge Solutions, NativeEdge
Propriétés de l’article
Numéro d’article: 000261316
Type d’article: Solution
Dernière modification: 22 Apr 2025
Version:  2
Trouvez des réponses à vos questions auprès d’autres utilisateurs Dell
Services de support
Vérifiez si votre appareil est couvert par les services de support.