Dell NativeEdge : Le téléchargement à partir du catalogue échoue avec le message « Internal Server Error »
Résumé: Dans NativeEdge Orchestrator 3.0.0.0, le téléchargement à partir du catalogue peut échouer avec le message « Internal Server Error »
Symptômes
Dans NativeEdge Orchestrator 3.0.0.0, une nouvelle fonctionnalité est introduite pour télécharger directement des blueprints et des plug-ins au sein de NativeEdge Orchestrator dans un environnement non isolé. Vous pouvez observer une « erreur interne du serveur » lorsque vous essayez de télécharger des plug-ins de plus grande taille.

Si vous examinez les journaux réseau à l’aide de l’outil de développement du navigateur, vous pouvez voir le message « Erreur de serveur interne 500 »

Cause
Cela se produit lorsqu’un téléchargement prend plus de 30 secondes. Les journaux du back-end de stage génèrent l’erreur ci-dessous.
message: "Requested URL: /plugins?title=Nativeedge%20Gcp%20Plugin&visibility=tenant&package_name=nativeedge-gcp-plugin&plugin_archive_url=https%3A%2F%2Fdownloads.dell.com%2FFOLDER12410532M%2F1%2Fnativeedge-gcp-plugin_1.10.10.0_J34CH.wgn ECONNABORTED timeout of 30000ms exceeded"
Résolution
L’erreur « 500 internal server error » est une fausse alerte. Dans la plupart des cas, le fichier de plug-in est téléchargé avec succès.
Les utilisateurs peuvent actualiser l’interface de « Download from Catalog ». Le plugin téléchargé s’affiche correctement.

Si la solution ci-dessus ne fonctionne pas, contactez le support Dell pour poursuivre le dépannage.
Le correctif sera disponible dans la prochaine version de NativeEdge.