No se puede acceder a la interfaz de usuario web después de la actualización a OpenManage Enterprise 4.6.0 mientras se aprovecha la configuración "Restringir rangos de IP permitidos"
Resumen: Durante la tarea posterior a la actualización, la aplicación de los rangos de IP falla si hay entradas de rango de IP no canónicas. Esto hace que la restauración de la tabla de IP se detenga, lo que hace que ya no se pueda acceder a la interfaz de usuario web. ...
Síntomas
Después de la actualización a la versión 4.6.0, no se puede acceder a la interfaz de usuario web. El sitio regresa con un ERR_CONNECTION_TIMED_OUT al intentar cargar.

Causa
En OpenManage Enterprise 4.6, el paquete firewalld se actualiza de la versión 0.9.3 a la 2.0.1. Firewalld 0.9.3 aceptó silenciosamente cadenas de enrutamiento de interdominio sin clases (CIDR) no canónicas (por ejemplo, 100.94.15.0/21), por lo que el ipset Podría almacenar rangos con bits de host configurados.
Sin embargo, firewalld 2.0.1 normaliza automáticamente cada cadena de CIDR a su formato de red (100.94.8.0/21). Esto entra inmediatamente en conflicto con las entradas no canónicas preexistentes que aún están presentes en el archivo ipset regla. La variable ipset La carga falla con 'INVALID_ENTRY overlaps' (100.94.8.0/21 se superpone con 100.94.15.0/21), lo que hace que la operación de restauración de iptables se cancele.
Resolución
Antes de actualizar a la versión 4.6, revise los rangos de IP actuales que se encuentran en Configuración de la aplicación - Seguridad - Restringir rangos de IP permitidos.

Asegúrese de que los rangos IP configurados no se superpongan. En el ejemplo anterior, hay dos rangos que activarían el problema:
- 192.168.2.0/24
- 192.168.2.2/24
Para mitigar el problema, aproveche una de las siguientes soluciones alternativas:
- Modifique los rangos IP antes de actualizar a la versión 4.6 mediante la eliminación del rango superpuesto o la modificación de los rangos para que sean canónicos.
- Otra opción es deshabilitar los ajustes temporalmente hasta que se complete la actualización. La versión más reciente de firewalld dentro de la versión 4.6 normaliza automáticamente los rangos de IP.
¿Ya actualizó a la versión 4.6 y no se puede acceder a la interfaz de usuario web? Revertir a una instantánea/punto de control funcional antes de iniciar la actualización a 4.6. Utilice una de las soluciones alternativas anteriores y vuelva a intentar la actualización.