OpenManage Enterprise 4.6.0 yükseltmesi sonrası 'İzin Verilen IP Aralıklarını Kısıtla' ayarı kullanılırken Web Kullanıcı Arayüzüne erişilemiyor
Summary: Yükseltme sonrası görev sırasında, kurallı olmayan IP aralığı girişleri varsa IP aralıklarının uygulanması başarısız olur. Bu, IP tablosu geri yüklemesinin durmasına ve web kullanıcı arayüzüne artık erişilememesine neden olur. ...
Symptoms
4.6.0 sürümüne yükseltme sonrasında web kullanıcı arayüzüne erişilemez. Site bir ERR_CONNECTION_TIMED_OUT yüklemeye çalışırken.

Cause
OpenManage Enterprise 4.6 içinde, güvenlik duvarı paketi 0.9.3 sürümünden 2.0.1 e yükseltilir. Firewalld 0.9.3, kurallı olmayan sınıfsız etki alanları arası yönlendirme (CIDR) dizelerini (örneğin, 100.94.15.0/21) sessizce kabul etti, bu nedenle ipset Ana bilgisayar bitleri ayarlanmış aralıkları depolayabilir.
Ancak, firewalld 2.0.1 her CIDR dizesini otomatik olarak ağ biçimine (100.94.8.0/21) normalleştirir. Bu, hala mevcut olan önceden var olan kanonik olmayan girişlerle hemen çelişir. ipset Kural. Komutta ipset yükleme daha sonra 'INVALID_ENTRY overlaps' (100.94.8.0/21, 100.94.15.0/21 ile çakışıyor) ve iptables geri yükleme işleminin iptal edilmesine neden oluyor.
Resolution
4.6 sürümüne yükseltmeden önce, Uygulama Ayarları - Güvenlik - İzin Verilen IP Aralıklarını Kısıtla altında bulunan geçerli IP aralıklarınızı gözden geçirin.

Yapılandırılan IP aralıklarının çakışmadığından emin olun. Yukarıdaki örnekte, sorunu tetikleyecek iki aralık vardır:
- 192.168.2.0/24
- 192.168.2.2/24
Sorunu azaltmak için aşağıdaki geçici çözümlerden birini kullanın:
- Sürüm 4.6'ya yükseltmeden önce, çakışan aralığı kaldırarak veya aralıkları kurallı olacak şekilde değiştirerek IP aralıklarını değiştirin.
- Başka bir seçenek de yükseltme tamamlanana kadar ayarları geçici olarak devre dışı bırakmaktır. 4.6 sürümü içindeki firewalld'un daha yeni sürümü, IP aralıklarını otomatik olarak normalleştirir.
Zaten 4.6 sürümüne yükselttiniz ve web kullanıcı arayüzüne erişilemiyor mu? 4.6 yükseltmesini başlatmadan önce çalışan bir anlık görüntüye/kontrol noktasına geri dönün. Yukarıdaki geçici çözümlerden birini kullanın ve yükseltmeyi yeniden deneyin.