Symptoms
When using the ECS UI to track operations (bucket operations, so on) the audit trail (Monitor > Events > Audit) fails to populate with the relevant information. Instead, generate the below error output:
Error 7000 (http: 500): An error occurred in the API Service. An error occurred in the API service. Cause: error listing audit events.
Audit logs of operations should fail to populate in this scenario.
Note: Instances of this issue can be intermittent in nature (that is: The error banner may generate once and not appear on a retry, but the issue may still be valid).
Cause
This is a known code issue that can occur prior to ECS code version 3.4.0.1 GP 1.
Resolution
A resolution for this issue is in ECS code 3.4.0.1 GP 1.
A workaround using the CLI is available by generating the raw.xml output as below (
Note: Removing the pipe in the command below before the head
-12, it generates further audit log information.):
admin@ecs1:~> svc_rest_cmd /vdc/events | head -12 svc_rest_cmd 1.0.10 <?xml version="1.0" encoding="UTF-8" standalone="yes"?> <auditevents> <auditevent> <description>User emcservice logged in successfully</description> <eventType>Update</eventType> <id>urn:storageos:Event:xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</id> <namespace/> <resourceId>emcservice</resourceId> <serviceType>Login</serviceType> <timestamp>2020-01-23T12:45:27</timestamp> <userId>emcservice</userId> </auditevent>
If further assistance is required, open a Service Request with ECS Support and reference this KB article in the Service Request's notes.
Additional Information
The REST API Reference Guide is available from the ECS download page. Which is on the Dell support website.