Síntomas
We moved the VNX to a new location in the DataCenter and we are unable to reconnect to DELL EMC SRS services
New SRS connections can not be made with a SRS Device Client.
This issue affects the following systems:
- All VNX models
- eNAS
- All VNXe models
- VNXe1000 Series models that uses ESRS internal client
Causa
Due to Dell security hardening SSLv3 API has been disabled and been replaced with TLSv1.2, However the internal "ESRS" IP DeviceClients are still using SSLv3 API.
This is not a code bug, but it is loss of functionality due to Dell security hardening.
If the VNXe or VNX are disconnected (moved) from SRS, they will not be able to re-connect for Dial Home or Connect Home.
Support will not be able to remote connect until customer installs SRS Centralized Server VE (VMware or Hyper-V) or DE (Linux x64 Docker).
Resolución
There is no solution to provision a new instance of a SRS 2.x device - the agent relied on insecure technology which Dell Cybersecurity has been providing an exception for years now on but as of Oct 31st it has to be disabled permanently. This has been tested and Verified by Engineering.
The solution for a customer in this situation will be to deploy against a
SRS Centralized Server.
Secure Remote Services Virtual Edition
https://www.dell.com/support/home/us/en/04/product-support/product/emc-secure-remote-services-virtual-edition/overview
Version 3.42
Standard Support: 15 JAN 2020
Quick Summary of the Install options for SRS Centralized Server
There are two install options for SRS:
- SRS Virtual Edition (SRS VE) using VMware vSphere OVF Template or Microsoft Hyper-V VHD Template.
- SRS can be run 100% virtually
- No additional hardware required
- No additional OS licenses required
- SRS Docker Edition (SRS DE) for Linux Distributions (x64 bit)
- Can be run on a qualified Linux environment that supports Docker containers
Search Secure Remote Services Virtual Edition Documentation
Manuals and Documents
https://www.dell.com/support/home/us/en/04/product-support/product/emc-secure-remote-services-virtual-edition/docs
Secure Remote Services 3.42.10.06 Release Notes
https://support.emc.com/docu97339_Secure_Remote_Services_3.42.10.06_Release_Notes.pdf?language=en_US&source=Coveo
Last Modified: 25 Feb 2020
Secure Remote Services 3.42 Quick Install Guide
https://support.emc.com/docu96993_Secure_Remote_Services_3.42_Quick_Install_Guide.pdf?language=en_US&source=Coveo
Last Modified: 13 Feb 2020
Secure Remote Services 3.42 Installation Guide
https://support.emc.com/docu96989_Secure_Remote_Services_3.42_Installation_Guide.pdf?language=en_US&source=Coveo
Last Modified: 13 Feb 2020
Dell EMC Unity: Centralized SRS Network Requirements (User Correctable)
Article Number 000534129
https://support.emc.com/kb/534129
Productos afectados
VNX/VNXe
Productos
eNAS, VNX1 Series, VNX2 Series, VNXe1 Series, VNXe1000 Series, VNXe2 Series, VNX/VNXe