Errore VPLEX: Impossibile svuotare il writer, spazio insufficiente sul dispositivo

Summary: Questo articolo descrive in dettaglio un problema per cui il comando di controllo integrità di VPLEX segnala log4j: ERRORE 'Impossibile svuotare il writer, causa: Nessuno spazio rimasto sul dispositivo'. Questo articolo fornisce la procedura alternativa per risolvere il problema. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Il comando di controllo integrità VPLEX riporta il seguente errore:

VPlexcli:/> health-check
log4j:ERROR Failed to flush writer,
cause: No space left on device
Product Version: 5.5.2.02.00.03
Product Type: Metro
WAN Connectivity Type: FC
Hardware Type: VS2
Cluster Size: 2 engines
Cluster TLA:
cluster-1: CKM00xxxxxxxxx
cluster-2: CKM00xxxxxxxxx

Cluster    Cluster  Oper   Health    Connected  Expelled  Local-com  
Name       ID       State  State                                     
---------  -------  -----  --------  ---------  --------  ---------  
cluster-1  1        ok     ok        True       False     ok
cluster-2  2        ok     degraded  True       False     ok


La pulizia dei file è necessaria per ridurre il /var/log Livello di partizione della directory.
 

Cause

Non viene lasciato alcuno spazio sul /var/log . Il livello di partizione ha raggiunto il 100%:

service@vplexnkdc01:~> df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda5        20G  7.8G   11G  44% /
udev            1.9G  184K  1.9G   1% /dev
tmpfs           1.9G     0  1.9G   0% /dev/shm
/dev/sda1       504M   76M  403M  16% /boot
/dev/sda7        16G   16G     0 100% /var/log   <<<<<<<<<<<<<<<<<<
/dev/sda8        44G   27G   16G  64% /diag
/dev/sda9       9.9G  151M  9.2G   2% /data

Resolution

Soluzione:
Per controllare l'utilizzo della partizione, digitare df-h Al prompt del server di gestione, eseguire il seguente comando:

Service@ManagementServer:~> df-h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda5        20G  7.8G   11G  44% /
udev            1.9G  184K  1.9G   1% /dev
tmpfs           1.9G     0  1.9G   0% /dev/shm
/dev/sda1       504M   76M  403M  16% /boot
/dev/sda7        16G   16G     0 100% /var/log    <<<<<<<<<<<<<<<
/dev/sda8        44G   27G   16G  64% /diag
/dev/sda9       9.9G  151M  9.2G   2% /data


Procedura per la risoluzione dei problemi:

  1. Per ridurre il livello di partizione, fare riferimento all'articolo della knowledgebase riportato di seguito: VPLEX: 0x8a4a91fa / 0x8a4a31fb Partizioni del server di gestione piene o superate xx partizioni del server di gestione piene
    Se l'utilizzo di /var/log rimane al di sopra della soglia, dopo aver seguito l'articolo della Knowledge Base, seguire il passaggio 2.
  2. Potrebbero esserci più problemi che hanno causato il /var/log/ cartella sul server di gestione da riempire al 100% a causa della net-snmpd.log non ruotata correttamente.
    Verificare l'utilizzo del net-snmpd.log registro su /var/log Contesto. Se net-snmpd.log consuma più utilizzo, quindi è necessario ricaricare o riavviare il net-snmpd log.
    Fare riferimento agli articoli della Knowledge Base per ruotare/ricaricare il net-snmpd.log:
    VPLEX: /var/log/ che si riempie a causa di net-snmpd.log che non ruotano correttamente
  3. Controllare lo spazio su disco per assicurarsi che la modifica sia riflessa:
ManagementServer:/var/log # df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda5        20G  7.3G   11G  41% /
udev            1.9G  136K  1.9G   1% /dev
tmpfs           1.9G   68M  1.8G   4% /dev/shm
/dev/sda1       504M  111M  368M  24% /boot
/dev/sda7        16G  2.4G   13G  16% /var/log
/dev/sda8        44G   27G   16G  64% /diag
/dev/sda9       9.9G  260M  9.1G   3% /data
  1. Se dopo aver seguito queste azioni, il problema persiste, contattare l'assistenza clienti Dell e fare riferimento a questo articolo.

Affected Products

VPLEX, VPLEX GeoSynchrony

Products

VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000168666
Article Type: Solution
Last Modified: 12 ديسمبر 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.