NetWorker: Restore performed through NetWorker User reports the error "Please Specify AM or PM" When attempting to change browse time.

Summary: A recovery is being performed from the NetWorker User software, when attempting to change browse time an error appears stating: "PM@#$%# is not a valid time designation in 12-hour format. Please Specify AM or PM" ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • A restore is being performed using the NetWorker User program.
  • The following error when changing browse time using 12-hour format.
Not a valid time designation in 12 hour format 

Cause

Code defect. Observed using NetWorker 19.7.0.1 client on Windows Server 2016. NetWorker 19.7 is End of Support Life (EOSL).

 

Resolution

This issue was not observed when using NetWorker 19.11.0 (or later) client on Windows Server 2022 or 2025. This issue is unlikely on current NetWorker releases and operating systems. If encountered, use the workaround below.

Workaround: 

  1. From NetWorker User, select View->Change Browse Time
  2. Specify a time (in a 12-hour format) that you would like to set the browse period to. Insert a space before AM or PM.
There is a space preceding the AM PM in the time settings
  1. Click Ok
  2. The browse time should now reflect the time that is specified.

Affected Products

NetWorker Family, NetWorker

Products

NetWorker Series
Article Properties
Article Number: 000201625
Article Type: Solution
Last Modified: 30 ديسمبر 2025
Version:  3
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