NetWorker: NMCDB backups failed 19240:savepsm: Failed to get NetWorker Management Console install directory.
Summary: NMCDB backups failed 19240:savepsm: Failed to get NetWorker Management Console install directory.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Moved NMC server database to another host post changing facing issues with GSTD services and or NMCDB backup failure
Error:
Error:
19239:savepsm: Failed to open registry to get GSTD install path. 19240:savepsm: Failed to get NetWorker Management Console install directory.
Cause
The backups are failing because the group is still with NetWorker server name and it is assigned to NMC server group.
Resolution
To solve this issue :-
1) Uninstall NMC software
2) Rename the 'Management' folder
3) Install the NetWorker Management Console software again
4) Go to NMC console Remove the old client name under NMC server group.
5) Create the client with the new NMC server name and then assign it to NMC server group.
6) Test the NMCDB backup, above steps should solve the issue.
1) Uninstall NMC software
2) Rename the 'Management' folder
3) Install the NetWorker Management Console software again
4) Go to NMC console Remove the old client name under NMC server group.
5) Create the client with the new NMC server name and then assign it to NMC server group.
6) Test the NMCDB backup, above steps should solve the issue.
Products
NetWorker FamilyArticle Properties
Article Number: 000207282
Article Type: Solution
Last Modified: 20 يناير 2026
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.