PowerScale InsightIQ 5.x zeigt den letzten Updatezeitstempel nach dem Import aus 4.x als 2020 oder 2021 an

Summary: Die InsightIQ 5.x-WebUI zeigt aufgrund einer veralteten Tabelle in der Datenbank einen falschen Zeitstempel für die letzte Aktualisierung an.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Cluster zeigt die letzte Aktualisierung mit einem Zeitrahmen von 2020 oder 2021 an.

Cause

Dies ist auf eine system_workload Tabelle in der Datenbank, die seit 2020 oder 2021 nicht mehr aktualisiert oder verwendet wird. Dies ist nur bei älteren importierten Datenspeichern der Fall. 

Resolution

Beheben Sie das Problem system_workload Problem mit der Verzögerung beim Datenabruf 2020.


Überprüfen Sie, wo die Datenbank gespeichert wird: 

# kubectl get pvc -A | grep storage


Navigieren Sie zum richtigen Abschnitt basierend auf dem Speichertyp:

Lokaler Speicher:

# kubectl get pods -A | grep ha-cmo 
 # kubectl exec -it postgres-ha-cmo1-xxxx-x -n atlantic -- psql 
 # \l
 # \c clustername_guid   <<<< get the clustername_guid from \l above for the cluster in question >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # delete from data_time where api='system_workload';
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # \q

Aktualisieren Sie den Bildschirm nach ca. 5 bis 10 Minuten und stellen Sie sicher, dass das Datum normal ist. Wenn das Datum nicht normal ist, überprüfen Sie zur Bestätigung erneut die Tabellen system_workload Folgendes wurde nicht neu erstellt:

# kubectl exec -it postgres-ha-cmo1-xxxx-x -n atlantic -- psql 
 # \l
 # \c clustername_guid   <<<< get the clustername_guid from \l above for the cluster in question >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;


NFS-Storage (Network File System):

# kubectl get pods -A | grep iiqsm  
 # kubectl exec -it iiqsm-psql-XXXX-xxxx -n atlantic -- psql -U iiqsm -h localhost -d postgres
 # \l
 # \c clustername_guid  <<<< get the clustername_guid from \l above for the cluster in question >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # delete from data_time where api='system_workload';
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # \q

 

Aktualisieren Sie den Bildschirm nach ca. 5 bis 10 Minuten und stellen Sie sicher, dass das Datum normal ist. Wenn das Datum nicht normal ist, überprüfen Sie zur Bestätigung erneut die Tabellen system_workload wurde nicht neu erstellt.

# kubectl exec -it iiqsm-psql-XXXX-xxxxx -n atlantic -- psql -U iiqsm -h localhost -d postgres
 # \l
 # \c clustername_guid  <<<< clustername_guid from \l above >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;

Affected Products

PowerScale InsightIQ
Article Properties
Article Number: 000230681
Article Type: Solution
Last Modified: 16 ديسمبر 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.