PowerScale InsightIQ 5.x muestra el último registro de fecha y hora de actualización como 2020 o 2021 después de la importación desde 4.x

Summary: La interfaz de usuario web de InsightIQ 5.x muestra un registro de fecha y hora incorrecto de la última actualización debido a una tabla obsoleta en la base de datos.

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Symptoms

En el clúster, se muestra la última actualización con un período de 2020 o 2021.

Cause

Esto se debe a un system_workload en la base de datos que ya no se actualiza ni se utiliza desde 2020 o 2021. Esto solo se observa en almacenes de datos importados más antiguos. 

Resolution

Corrija el problema system_workload Problema de retraso en la recuperación de datos de 2020.


Compruebe dónde se almacena la base de datos: 

# kubectl get pvc -A | grep storage


Vaya a la sección correcta según el tipo de almacenamiento:

Almacenamiento local:

# kubectl get pods -A | grep ha-cmo 
 # kubectl exec -it postgres-ha-cmo1-xxxx-x -n atlantic -- psql 
 # \l
 # \c clustername_guid   <<<< get the clustername_guid from \l above for the cluster in question >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # delete from data_time where api='system_workload';
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # \q

Actualice la pantalla después de unos 5 a 10 minutos y verifique que la fecha sea normal. Si la fecha no es normal, vuelva a revisar las tablas para verificar system_workload No se volvió a crear:

# kubectl exec -it postgres-ha-cmo1-xxxx-x -n atlantic -- psql 
 # \l
 # \c clustername_guid   <<<< get the clustername_guid from \l above for the cluster in question >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;


Almacenamiento NFS (Network File System):

# kubectl get pods -A | grep iiqsm  
 # kubectl exec -it iiqsm-psql-XXXX-xxxx -n atlantic -- psql -U iiqsm -h localhost -d postgres
 # \l
 # \c clustername_guid  <<<< get the clustername_guid from \l above for the cluster in question >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # delete from data_time where api='system_workload';
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # \q

 

Actualice la pantalla después de unos 5 a 10 minutos y verifique que la fecha sea normal. Si la fecha no es normal, vuelva a revisar las tablas para verificar system_workload no se recreó.

# kubectl exec -it iiqsm-psql-XXXX-xxxxx -n atlantic -- psql -U iiqsm -h localhost -d postgres
 # \l
 # \c clustername_guid  <<<< clustername_guid from \l above >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;

Affected Products

PowerScale InsightIQ
Article Properties
Article Number: 000230681
Article Type: Solution
Last Modified: 16 ديسمبر 2025
Version:  5
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