PowerScale InsightIQ 5.x mostra il timestamp dell'ultimo aggiornamento come 2020 o 2021 dopo l'importazione dalla versione 4.x

Summary: L'interfaccia utente web di InsightIQ 5.x mostra un timestamp dell'ultimo aggiornamento errato a causa di una tabella obsoleta nel database.

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Symptoms

Il cluster mostra l'ultimo aggiornamento con un intervallo di tempo del 2020 o 2021.

Cause

Ciò è dovuto a un system_workload Tabella nel database che non viene più aggiornata o utilizzata dal 2020 o 2021. Questo problema si verifica solo nei datastore importati meno recenti. 

Resolution

Correggere il problema system_workload Problema del ritardo nel recupero dei dati del 2020.


Verificare la posizione in cui è archiviato il database: 

# kubectl get pvc -A | grep storage


Passare alla sezione corretta in base al tipo di storage:

Archiviazione locale:

# kubectl get pods -A | grep ha-cmo 
 # kubectl exec -it postgres-ha-cmo1-xxxx-x -n atlantic -- psql 
 # \l
 # \c clustername_guid   <<<< get the clustername_guid from \l above for the cluster in question >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # delete from data_time where api='system_workload';
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # \q

Aggiornare lo schermo dopo circa 5-10 minuti e verificare che la data sia normale. Se la data non è normale, controllare nuovamente le tabelle per verificare system_workload non ha ricreato:

# kubectl exec -it postgres-ha-cmo1-xxxx-x -n atlantic -- psql 
 # \l
 # \c clustername_guid   <<<< get the clustername_guid from \l above for the cluster in question >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;


Storage NFS (Network File System):

# kubectl get pods -A | grep iiqsm  
 # kubectl exec -it iiqsm-psql-XXXX-xxxx -n atlantic -- psql -U iiqsm -h localhost -d postgres
 # \l
 # \c clustername_guid  <<<< get the clustername_guid from \l above for the cluster in question >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # delete from data_time where api='system_workload';
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;
 # \q

 

Aggiornare lo schermo dopo circa 5-10 minuti e verificare che la data sia normale. Se la data non è normale, controllare nuovamente le tabelle per verificare system_workload non ha ricreato.

# kubectl exec -it iiqsm-psql-XXXX-xxxxx -n atlantic -- psql -U iiqsm -h localhost -d postgres
 # \l
 # \c clustername_guid  <<<< clustername_guid from \l above >>>>>>
 # SELECT api, time FROM data_time WHERE resolution = 5 AND api NOT LIKE 'cluster_%%%%' order by time;

Affected Products

PowerScale InsightIQ
Article Properties
Article Number: 000230681
Article Type: Solution
Last Modified: 16 ديسمبر 2025
Version:  5
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