"Email address not found" Error When Attempting to Log Into TechDirect With EntraID

Summary: Learn what to do when logging in to Dell TechDirect using Microsoft EntraID gives an "Email address not found" error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Attempting to log in to Dell TechDirect using Microsoft EntraID may result in an "Email address not found" error.

Affected Products:

  • Dell TechDirect
  • Microsoft EntraID

Cause

This happens if the user profile in Microsoft EntraID does not have the email attribute set.

Resolution

  1. Log in to the Microsoft Entra admin centerThis hyperlink is taking you to a website outside of Dell Technologies..
  2. Go to the User section and search for the impacted user.
  3. Open the User properties and then go to Contact Information.
  4. If the attribute is blank, update the user’s profile to include their email address.
  5. Save the settings.
  6. Clear the browser cache and attempt to log in to Dell TechDirect again.

Affected Products

TechDirect Connected Provisioning
Article Properties
Article Number: 000387787
Article Type: Solution
Last Modified: 24 مايو 2026
Version:  3
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