SourceOne Email Management: SourceOne Databases Fail to Upgrade

Summary: SourceOne database fails to upgrade when updating the SourceOne to a later version.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SourceOne databases fail to upgrade when updating SourceOne to a later version.

Unable to upgrade the database by running the ES1_ActivityDB_Update_mssql.bat file as SQLCMD was not working. The database was giving the below error when running the upgrade script.

Sqlcmd: Error: Connection failure.
SQL Native Client is not installed correctly. To correct this, run SQL Server Setup.

Cause

The path for the SQL server BIN folder was incorrect or missing.

Resolution

Correct or add the path for the SQLCMD BIN folder as follows:

  1. In the system Properties > Advance System Settings > Advance > Environment Variables > select Path from system variables.
  2. Edit the path as the location of SQLCMD, for example, C:\Program Files\Microsoft SQL Server\110\Tools\Binn\ 

The database can then connect, and the upgrade can continue by assigning the correct path for the SQLCMD to the path folder.

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000051898
Article Type: Solution
Last Modified: 04 يونيو 2026
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.