NetWorker: Il backup di Windows 2012 non riesce per DISASTER_RECOVERY con "save: Si è verificato un errore durante il salvataggio dei saveset di ripristino di emergenza"

Summary: Questo articolo illustra l'errore del saveset DISASTER_RECOVERY:\ durante i backup di Windows 2012 causato da un repository WMI Windows danneggiato. NetWorker non è in grado di recuperare i dati del produttore del sistema tramite WMI, causando l'errore. La correzione o la ricostruzione del repository WMI e l'aggiornamento del client Windows risolvono il problema. ...

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Symptoms

DISASTER_RECOVERY:\ non riesce a eseguire il backup su un computer Windows 2012.
Tutti gli altri saveset (ad esempio unità, cartelle o file) vengono completati correttamente.

I saveset WINDOWS ROLES AND FEATURES e backup delle unità critiche eseguito correttamente.

L'unico errore visualizzato è

save: Error occured while saving disaster recovery save sets

L'ultima voce nell'output di salvataggio è (nessun errore visualizzato):

create_ossr_info_file: Calling get_system_manufacturer_info
Quando si esegue il backup nel livello di debug 5, vengono annotati i seguenti errori verso la fine del registro:
machine_name: WINDOWS ROLES AND FEATURES:\ level=full, 6636 KB 00:00:02     21 files
Completed savetime=1442493321
09/17/15 14:35:23.961661 Unregistered session id:2, fd:1420, idx:1, ssn_max_pollfd:1, 1(512)
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to disk_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to pool_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to volume_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to partition_free_list()
09/17/15 14:35:23.992862 nsr/libwinclass/ossr_sysinfo_xml.cpp: NULL pointer passed to adapter_free_list()
86024:save: Error occured while saving disaster recovery save sets.

Cause

Durante DISASTER_RECOVERY:\ backup, NetWorker utilizza WMI (componente del sistema operativo) per ottenere informazioni sui computer client (ad esempio nome di dominio, produttore, nome del computer e memoria fisica) che vengono quindi popolate nel file DISASTER_RECOVERY:\ Metadati. In questo caso, la WMI della macchina è danneggiata e NetWorker non è in grado di recuperare i dati dalla WMI, generando un errore di backup.

Il problema è con Windows WMI. L'errore si verifica quando NetWorker utilizza una query WMI per ottenere le informazioni del produttore del sistema da archiviare con il DISASTER_RECOVERY:\ Metadati del saveset.
 
Esecuzione di Get-WmiObject Win32_Computersystem from Powershell ha esito negativo con un messaggio di operazione non valida. Per verificare se WMI è danneggiato o meno, eseguire il seguente comando su Windows PowerShell su tale computer.
 
Un buon output dovrebbe essere:
PS C:\> Get-WmiObject Win32_Computersystem

Domain         : emc.com
Manufacturer   : VMware, Inc.
Model          : VMware Virtual Platform
Name                : LIME
PrimaryOwnerName    : Windows User
TotalPhysicalMemory : 2146951168

Se viene visualizzato un altro output, significa che WMI è danneggiato e non è in grado di rispondere alle chiamate del sistema operativo. Di seguito è riportato un esempio di WMI danneggiata:
PS C:\Users\Adam.Boesl> Get-WmiObject Win32_Computersystem
Get-WmiObject : Invalid class
At line:1 char:14
+ Get-WmiObject <<<<  Win32_Computersystem
    + CategoryInfo          : InvalidOperation: (:) [Get-WmiObject], ManagementException
    + FullyQualifiedErrorId : GetWMIManagementException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

Resolution

I backup di Windows Server 2012 sono elencati come supportati nelle Guide alla compatibilità di NetWorker. Esaminare le guide alla compatibilità per la versione di NetWorker in uso: E-Lab Interoperability Navigator 2.0-HOME (è necessario accedere con l'account del supporto Dell).
Tuttavia, questo problema si verifica sul sistema operativo Windows. Le funzionalità di supporto sono limitate per problemi a livello di sistema operativo su piattaforme non più supportate dal fornitore.

Accertarsi che nel sistema operativo client siano installati gli aggiornamenti più recenti del sistema operativo. Se i backup del Servizio Copia Shadow del volume (VSS) continuano a non riuscire, è possibile analizzare i componenti VSS. L'analisi del componente VSS e le funzionalità del sistema operativo devono essere analizzate dal System Administrator.  

Se il problema del sistema operativo non può essere risolto, eseguire i backup dei dati del file system del client senza VSS.

  1. Configurare le operazioni di salvataggio del client per includere VSS:*=OFF:
    Backup di un client Windows senza VSS 
    NOTA: View:> per visualizzare l'impostazione delle operazioni di salvataggio, è necessario abilitare la modalità diagnostica in NMC.
  2. Aggiornare il campo dei saveset del client in modo da includere solo file, cartelle o volumi. Ad esempio:
AVVERTENZA: Senza VSS, non è possibile eseguire backup basati su blocchi (BBB) o backup coerenti DISASTER_RECOVERY:\. È possibile eseguire il backup dei dati del file system senza VSS; tuttavia, non sarebbe possibile eseguire un ripristino bare-metal (BMR) senza backup DISASTER_RECOVERY:\.

Additional Information

Ciò si applica a tutte le versioni di NetWorker e solo ai computer Windows 2012 e Windows 2012 R2.

NOTA: questo problema è stato osservato anche con Windows Server 2008; tuttavia, questo sistema operativo non è più supportato per i backup di NetWorker.

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000018662
Article Type: Solution
Last Modified: 27 نيسان 2026
Version:  5
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