NetWorker: Come utilizzare nsrclientfix, errore "Impossibile trovare l'attributo 'client id'"

Summary: Come usare nsrclientfix per identificare e risolvere i problemi del cliente su un server NetWorker.

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Symptoms

Il comando nsrclientfix viene usato per l'analisi del database dei supporti allo scopo di rilevare il danneggiamento dell'ID client.
Può inoltre unire i client sia nel database delle risorse che nel database dei supporti.

Uno o più clienti hanno più di un cliente.
98519:save: Unable to setup direct save with server <nw_server>: Cannot find attribute 'client id'..
90018:save: Cannot open a save session with NetWorker server '<nw_server>': Cannot find attribute 'client id'.
<nw_client>:/etc: retried 2 times.

Cause

  • La causa generale è un client che si identifica nel database dei supporti durante un backup come nome che il server NetWorker non riconosce essere un alias.
  • Ciò può anche essere causato dalla creazione di una risorsa client con un nome diverso da quello scelto (nome client) per rappresentare il client.
  • Un cattivo aliasing nel file hosts del sistema può causare questo tipo di problema. Prima di intraprendere ulteriori azioni, è necessario apportare correzioni al file hosts. 
 

Resolution

Prerequisiti

Attenersi alla seguente procedura prima di modificare gli indici dei file del client NetWorker.

1. Eseguire un "Server Protection Backup" per eseguire il backup degli indici esistenti, del database dei supporti (mm) e del database delle risorse NetWorker (nsrdb) esistenti
 
NOTA: Il comando nsrclientfix modifica sia il database dei supporti che quello di configurazione. In caso di problemi o errori, si consiglia di eseguire un backup di entrambi i database.

Raccogliere le informazioni sul saveset di bootstrap con: mminfo -B

2. Arrestare i daemon di NetWorker sul server NetWorker:
Linux: systemctl stop networker(or nsr_shutdown)
Windows: net stop nsrexecd /y
 
3. Verificare che tutti i daemon di NetWorker siano inattivi:
Linux: ps -ef | grep nsr
Windows:tasklist | findstr nsr

4. Oltre al backup di protezione del server, è possibile creare copie delle cartelle mm e nsrdb sul server NetWorker.
A. mm: Linux: /nsr/mm Windows: .\Program Files\EMC NetWorker\nsr\mm
B. nsrdb: Linux: /nsr/res/nsrdb Windows: .\Program Files\EMC NetWorker\nsr\res\nsrdb
C. nsrladb: Linux: /nsr/res/nsrladb Windows: .\Program Files\EMC NetWorker\nsr\res\nsrladb
D. A seconda delle dimensioni dell'indice e dello spazio disponibile sul server, l'indice può anche essere copiato: Linux: /nsr/index Windows: .\Program Files\EMC NetWorker\nsr\index
 
5. Avviare i servizi NetWorker:
Linux: systemctl start networker
Windows: net start nsrd 
 

Processo
 

1. Identificare quali client hanno problemi con i clienti. Il comando seguente verifica solo la presenza di eventuali problemi, ma non esegue alcuna azione correttiva. 


Sintassi:
nsrclientfix -a - -p

Esempio:
nsrclientfix -a - -p
alenka, alenka.emc.com <-- Uno o più client
Temporal <-- Un client
localhost <-- Un client
 
Il formato del file letto e quello generato sono identici. Il file è costituito da un elenco separato da virgole di client separati da nuove righe. Il numero di client sulla riga rappresenta le azioni intraprese.
 
3. Creare un file di testo con l'elenco dei client che devono essere corretti da nsrclientfix
 
Sintassi:
nsrclientfix -afile-p
Questo comando non esegue alcuna azione correttiva. Crea il file di testo utilizzato da nsrclientfix per correggere i problemi.
 
Esempio:
nsrclientfix -atext1-p
Alenka, alenka.emc.com
temporale
localhost

4. Rivedere l'elenco dei client da unire.
Aprire il file di testo creato nel passaggio precedente ed esaminare ogni riga:
 
Un solo client
Quando sulla linea è presente un solo client, significa che è contrassegnato per essere eliminato. Questo problema non viene visualizzato durante la fase di analisi, a meno che non venga utilizzato il flag -p . I client vengono in genere segnalati per l'eliminazione (quando richiesto) quando esiste un client precedente senza voci del database delle risorse o dei supporti. Ciò è causato da vecchi client disattivati o dall'unione di un client in un altro.
 
Più di un client
Più di un client significa che i client elencati devono essere uniti. Il primo nome nell'elenco è il nome principale il cui nome e ID client vengono conservati (se esiste già). I seguenti nomi (nomi secondari) vengono uniti al nome primario. Tutte le risorse client dei nomi secondari vengono rinominate con il nome primario e gli elenchi di alias di tutti i client verranno combinati. Anche gli ID client e i nomi delle voci del database dei supporti verranno uniti nel nome principale.
 
NOTA: Se gli alias che si desidera unire, ad esempio "old name" e "new name" non vengono visualizzati sulla stessa riga, è necessario aggiungere il "old name" come alias NetWorker del "new name". Ad esempio: Aggiungere nwclientold o nwclientdummy come alias per nwclient.
 
AVVERTENZA: È importante verificare che tutti gli alias elencati sulla stessa riga appartengano allo stesso host. Se è presente un alias appartenente a un host diverso, nsrclientfix unisce i relativi saveset al primo alias nell'elenco. Se i saveset devono essere suddivisi in un secondo momento, è necessaria una soluzione alternativa complicata e dispendiosa in termini di tempo (in breve, rimuovere i saveset dal database dei supporti ed eseguire nuovamente la scansione).
.
5. Utilizzare nsrclientfix con il file di testo per correggere i problemi relativi ai client elencati.
 
Sintassi:
file

nsrclientfix -uEsempio:
nsrclientfix -utext1

Unione dei seguenti client in 'alenka': alenka.emc.com

Unione del database delle risorse per il client 'alenka'.

Unione del database dei supporti per il client 'alenka'.

L'unione è completa per il client 'alenka'.

Eliminazione del client "temporale".

Eliminazione del database delle risorse dal client 'temporal'.

Eliminazione del database dei supporti dal client 'temporal'.

Rimozione di eventuali backup dell'indice relativi al client "temporale" nel database dei supporti.

Client eliminato correttamente 'temporal'.

Eliminazione del client 'localhost'.

Eliminazione del database delle risorse del client 'localhost'.

Eliminazione del database dei supporti del client 'localhost'.

Rimozione di eventuali backup dell'indice relativi al client 'localhost' nel database dei supporti.

Il client 'localhost' è stato eliminato correttamente.

NOTA: I client uniti non verranno rimossi. Il comando nsrclientfix deve essere eseguito di nuovo per rimuovere gli alias che sono stati uniti e non rimossi.
 
6. Eliminare i client che sono stati precedentemente uniti e che ora non hanno saveset collegati.
I client uniti non sono stati rimossi. Per rimuoverli, è necessario eseguire nuovamente nsrclientfix:
 
nsrclientfix -atext2-p
alenka.emc.com
 
nsrclientfix -u testo2

Eliminazione del client 'alenka.emc.com'.

Eliminazione del database delle risorse del client 'alenka.emc.com'.

Eliminazione del database dei supporti dal client 'alenka.emc.com'.

Rimozione di tutti i backup dell'indice correlati al client "alenka.emc.com" nel database dei supporti.

Il client 'alenka.emc.com' è stato eliminato correttamente.

Additional Information

Per la man page di nsrclientfix, vedere l'allegato "nsrclientfix man page.pdf"

Affected Products

NetWorker

Products

NetWorker
Article Properties
Article Number: 000015252
Article Type: Solution
Last Modified: 14 كانون الثاني 2026
Version:  5
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