PowerFlex: Switch OS upgrade failed - transfer failed - IP address in OOB not PFMP subnet
Summary: This KB article describes an issue of being unable to upgrade the Switch OS using PFxM.
Symptoms
PowerFlex Management Platform (PFMP) nodes display Mgmt IP Addresses on the 10.10.10.x subnet:
Kubectl get nodes -o wide NAME STATUS ROLES AGE VERSION INTERNAL-IP pfx01mvm01 Ready control-plane,etcd,master 32d v1.24.7+rke2r1 10.10.10.10 pfx01mvm02 Ready control-plane,etcd,master 32d v1.24.7+rke2r1 10.10.10.11 pfx01mvm03 Ready control-plane,etcd,master 32d v1.24.7+rke2r1 10.10.10.12
Switch the IP Address from the inventory logs showing that it is on the 11.11.11.x subnet.
"mgmt1/1/1": {
"adminstatus": "up",
"bandwidth": "1000000000",
"description": "OOB",
"operstatus": "up",
"primary_ipv4": "11.11.11.15/24",
"type": "base-if:management"
Thin Deployer pod logs from the job performing the upgrade Switch OS job:
"stdout": [
"image download scp://admin@11.11.11.15:/tmp/PKGS_OS10-Enterprise-\u001bE10.5.4.5.201buster-installer-x86_64.bin",
"stdout_lines": [
"Image Upgrade State: idle",
"==================================================",
"File Transfer State: transfer-failed",
"--------------------------------------------------",
" State Detail: Failed: Couldn't connect to server",
Impact: Unable to upgrade the Switch OS using PFxM.
Cause
This is a recognized software code issue. When the Switch IP address is located on an OOB network rather than the PFMP Management subnet, PFxM encounters a failure in transferring the files for the upgrade.
This issue is mentioned in the PowerFlex 4.5 Release Notes for issue VXFM-35909.
Resolution
Manually upgrade the Switch OS.
See the section "Upgrade the Dell PowerSwitch Switches" of the Dell PowerFlex Rack with PowerFlex 4.x Upgrade Guide for instructions.
Additional Information
Impacted Versions: PowerFlex 4.x
Fixed In Version: TBD