Broadcom 100Gbps network card (BCM57608) support for Dell PowerEdge AMD servers and VMware ESXi

Summary: Broadcom network device BCM57608 is not initialized and detected on Dell customized VMware ESXi 8.x and 9.0. This KB is to detail the issue, and the solutions offered.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dell customized VMware ESXi 8.x and 9.0.0.0 fail to initialize BCM57608 network device on Dell PowerEdge AMD servers. The ESXi kernel logs indicate that “Unable to allocate 511 cookies: Out of resources” for the BCM57608 network ports. This is seen as part of “bnxtnet” network driver initialization during ESXi boot. 

Cause

Older firmware versions of BCM57608 set the default MSI-X vector requirement as 512 for a given Physical Function (PF). Dell customized VMware ESXi 8.x and 9.0.0.0 booted on these systems do not initialize BCM57608 stating that it is running out of MSI-X resources. This is because of a bug in ESXi related to interrupt allocation logic in AMD IOMMU. 

There is a known issue affecting ESXi 8.x and ESXi 9.0.0.0 branches. To resolve the issue, use the latest Network card firmware which is made available via support.dell.com. The issue is fixed in Dell customized ESXi 9.0.1.0 A03 which is available via Broadcom download page. 

Resolution

Use the latest network card firmware available at support.dell.com (OR) Use the Dell customized ESXi 9.0.1.0 A03 image. 
When the latest network card firmware is used, it is noticed that the MSI-X vectors value is set to 128 in the network device firmware settings. 

Affected Products

OEMR XL R6725, OEMR XL R7715, OEMR XL R7725, PowerEdge R6725, PowerEdge R7715, PowerEdge R7725, PowerEdge R7725xd, VMware ESXi 8.x, Dell vSAN R7715 Ready Node, Dell vSAN R7725 Ready Node

Products

VMware ESXi 9.x
Article Properties
Article Number: 000396996
Article Type: Solution
Last Modified: 27 تشرين الثاني 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.