VxRail: Update Failed to Scan Components
Summary: VxRail vLCM update from version 8.0.330 to 8.0.380 failed during the “Scan Components” stage.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The update process failed during Scan Components with error:
Recommended Action:Failed to scan components.

Cause
The issue occurs because the Hardware State Manager (HSM) microservice becomes unresponsive or stuck during the update process.
Resolution
Restart the Hardware State Manager (HSM) microservice to recover the stuck service and allow the vLCM workflow to proceed.
- Access the VxRail Manager by SSH.
- Verify the HSM pod status:
kubectl get pods | grep hsm
- Restart the HSM microservice by deleting the pod:
kubectl delete pod hsm-cc76b8d86-h2rmt
- Confirm that the new HSM pod is running:
kubectl get pods | grep hsm
- Retry the VxRail upgrade process from the VxRail Manager Plug-in.
Affected Products
VxRail, VxRail Appliance Series, VxRail SoftwareArticle Properties
Article Number: 000479336
Article Type: Solution
Last Modified: 08 تموز 2026
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.