PowerFlex: NTP Synchronization Troubleshooting and Validation

Summary: Incorrect system time on a server can lead to critical issues such as certificate validation failures, authentication errors, and upgrade failures.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

  • System time is incorrect or drifting
  • Certificate or TLS validation failures
  • Cluster nodes reporting inconsistent time
  • Upgrade or deployment failures related to time mismatch

Cause

NTP (via the chronyd service) is not running, misconfigured, or unable to synchronize due to excessive time drift or connectivity issues.

Resolution

Run the following command to confirm that the clock is synchronized with other systems and that the NTP service is active.

timedatectl status

 

Ensure the chrony service is running:

systemctl status chronyd

 

Check synchronization health and source servers, this will show offset and sync status, along with reachable NTP servers and their status:

chronyc tracking

chronyc sources -v

 

If the time is off by a few minutes, restart chrony

systemctl restart chronyd

 

If the system is not syncing properly, force a time correction

chronyc makestep

 

If the system time is significantly out of sync

  • NTP may not automatically adjust it. Manually set the time closer to the correct value:
sudo timedatectl set-time "YYYY-MM-DD HH:MM:SS"

 

Example:

sudo timedatectl set-time "2026-06-19 10:30:00"

 

Once corrected, chrony will resume normal synchronization.

 

After performing the steps, confirm that the system clock is synchronized and that an NTP source is active:

timedatectl status

chronyc tracking

Additional Information

Successful chronyc tracking status
A configured NTP server should be listed under Reference ID, Stratum should be a value greater than 0 and System Time should report much less than 1 second time difference: 

node1:~ # chronyc tracking
Reference ID : 64400012 (0.pool.ntp.org)
Stratum : 4
Ref time (UTC) : Mon Mar 07 17:15:39 2022
System time : 0.000001647 seconds slow of NTP time
Last offset : -0.000006101 seconds
RMS offset : 0.000020258 seconds
Frequency : 33.247 ppm slow
Residual freq : -0.000 ppm
Skew : 0.016 ppm
Root delay : 0.040418178 seconds
Root dispersion : 0.033837218 seconds
Update interval : 1024.6 seconds
Leap status : Normal

 

Unsuccessful chronyc tracking status

Stratum 0 means not synced and Leap status says Not synchronized: 

node1:~ # chronyc tracking
Reference ID : 00000000 ()
Stratum : 0
Ref time (UTC) : Thu Jan 01 00:00:00 1970
System time : 0.000000000 seconds fast of NTP time
Last offset : +0.000000000 seconds
RMS offset : 0.000000000 seconds
Frequency : 0.000 ppm slow
Residual freq : +0.000 ppm
Skew : 0.000 ppm
Root delay : 1.000000000 seconds
Root dispersion : 1.000000000 seconds
Update interval : 0.0 seconds
Leap status : Not synchronized

Affected Products

PowerFlex rack, ScaleIO, PowerFlex Software
Article Properties
Article Number: 000481224
Article Type: Solution
Last Modified: 29 حزيران 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.