NetWorker: daemon.raw shows error: "Unable to get authentication credentials for nsrmmd"

Summary: NetWorker server daemon.raw shows error: "Unable to get authentication credentials for nsrmmd"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker server's daemon.raw has a large amount of error message during backup:

nsrmmd#44 NSR severe The local server was unable to get its own authentication credentials: Unable to find a credential for program 'nsrmmd', daemon ID 390104 and instance number 4405 
nsrd NSR warning Failed to allocate save mmd since it was not started. Reject request id 15443 . 

Cause

There are a lot of nsrmmd processes running in NetWorker server with Data Domain DD Boost devices. Some of nsrmmd had timeout and could not be authenticated by NetWorker server.

In the storage node setting, "Dynamic nsrmmds" was disabled.

Resolution

After enabling "Dynamic nsrmmds" in storage node settings, the authentication error disappeared and backup completed successfully. 

1. Log in to the NetWorker Management Console (NMC).
2. From the Devices tab, go to Storage Nodes.
3. Right-click the storage node that is used by the backup and open the Properties.
4. From the General tab, under Device Management, check the Dynamic nsrmmds checkbox.

Additional Information

The following article also details TCP and OS kernel best practices that may assist with session: NetWorker: Best practices for networking configuration

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000199939
Article Type: Solution
Last Modified: 12 يناير 2026
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.