NetWorker: AIX Client backups fails with "not properly configured" message

Summary: The NetWorker AIX client backup with to complete with a configuration error message. The NetWorker Management Console (NMC) shows either a Blank hostname or Unicode Character as hostname. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The AIX Client NSRLA Certificate shows a blank name or a Unicode Character "" (U+2592) for the hostname in /nsr/res/nsrladb.

The backup session log shows:

DD/MM/YY HH:MM:SS lgto_parms failed: Client ' ' is not properly configured on the NetWorker Server
175297:save: Unable to set up the direct save with server '###.###.###': Client ' ' is not properly configured on the NetWorker Server
175024:save: Cannot open a save session with NetWorker server '###.###.###': Client ' ' is not properly configured on the NetWorker Server

Cause

The AIX client /etc/hosts file record is missing the local details or an invisible Unicode Character "" added. The affected AIX client uses the /etc/hosts when creating the NSRLADB database certificate and the entry is causing the problem.

Example blank entry in the NSRLADB database:

my-aixp8-1:/ # nsradmin -d /nsr/res/nsrladb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p nsrla
                        type: NSRLA;
               administrator: root, "user=root,host=";


Example Unicode character in the NSRLADB database:

my-aixp8-1:/ # nsradmin -d /nsr/res/nsrladb
NetWorker administration program.
Use the "help" command for help, "visual" for full-screen mode.
nsradmin> p nsrla
                        type: NSRLA;
               administrator: root, "user=root,host=▒";

Resolution

Include the AIX client hostname and IP in the local /etc/hosts file to populate the local NSRLADB database.

  1. Open an SSH session to the AIX client.
  2. Make a copy of the existing hosts file: cp /etc/hosts /etc/hosts_orig
  3. Stop the NetWorker services: nsr_shutdown
  4. Rename the existing NetWorker res directory: mv /nsr/res /nsr/res_old
  5. Start the NetWorker services: /etc/rs.nsr
  6. Validate the hostname in the online NSRLADB database: nsradmin -p nsrexec 
  7. Validate the hostname in the offline NSRLADB database: nsradmin -d /nsr/res/nsrladb
  8. Clear the NSR Peer information about NetWorker Server: NetWorker: Fixing inconsistent NSR peer information
  9. Run a backup of the affected AIX client.

Additional Information

If the folders /nsr/res, or /nsr/res/nsrladb cannot be renamed, perform the following:

  1. Fix the name in the nsrladb as text file to call it nsrladb_manually_fixed.
  2. Use the nsradmin "-i" option to input and merge the nsrladb:
# nsradmin -d /nsr/res/nsrladb -i /tmp/nsrladb_manually_fixed
  1. Stop NetWorker services: nsr_shutdown
  2. Start NetWorker services: /etc/rs.nsr

Affected Products

NetWorker

Products

NetWorker Family
Article Properties
Article Number: 000202546
Article Type: Solution
Last Modified: 15 مايو 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.