CloudLink: Yedeklemeden Geri Yükledikten Sonra Küme Düğümleri Arasında Senkronizasyon Kapatma Sorununu Çözme

Summary: Müşteri, her iki CloudLink küme düğümünün web portalında oturum açmayı sürdürebiliyor ancak her düğüm diğerini eşitleme olarak bildiriyordu. Ortam, CentOS 7.3 te (İşletim Sistemi) şifrelenmiş disklerde tümleşik ScaleIO 2.0.1.2 ile CloudLink 6.5 P01 çalıştırır. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Gözlemlenen Sorunlar

  • Web portalı oturum açma işlemi her iki CloudLink küme düğümünde de başarılı olur ancak her düğüm diğer düğümü "sync off" olarak bildirir.
  • Her iki düğümdeki disk alanı kontrolleri, kullanım sorunu olmadığını gösteriyor.
  • GUI denetimleri, belirgin bir hata ortaya çıkarmaz, ancak CloudLink kümesinde bir sertifika yoktur.
  • Bir küme düğümünün yeniden başlatılması diğer düğümün "senkronizasyon kapalı" durumunu temizlemez.
  • İkinci düğümün yeniden başlatılması da "sync off" durumunu değiştirmeden bırakır.

Cause

Ayrı geri yüklemelerden sonra tutarsız küme durumu

İki cloudlink sanal makinesi farklı zamanlarda yedeklemeden geri yüklendiği için cloudlink kümesi senkronize edilmedi. Bu zaman uyumsuz geri yükleme, düğümler arasında farklı yapılandırma verileri ve meta veriler ortaya çıkardı.

  • Her düğüm, küme veritabanının farklı bir anlık görüntüsünü yükleyerek düğüm tanımlayıcılarının eşleşmemesine neden oluyordu.
  • Küme sertifikaları yeniden oluşturulmadı veya paylaşılmadı, bu da kümeyi geçerli bir paylaşılan sertifikadan yoksun bıraktı.
  • Tutarsızlık, düğümlerin senkronize bir durum oluşturmasını engelleyerek her düğümün diğerini "sync off" olarak bildirmesine neden oldu.

Resolution

CloudLink Küme Senkronizasyonunu Kurtarma

Eylem Planı

  • Çalıştığı bilinen bir yedekten bir CloudLink düğümünü geri yükleyin.
  • Geri yüklenen düğümün yapılandırmasından kalan küme üyelerini kaldırın.
  • OVA paketinden yeni bir CloudLink örneği dağıtın.
  • Yeni dağıtılan CloudLink in mevcut kümeye eklenmesi.

Adım Adım Prosedür

  1. Bir CloudLink düğümünü geri yükleme

    Bozulma meydana gelmeden önce alınan yedeği kullanın. 

  2. Geri yüklenen düğümden diğer küme üyelerini silme

    Geri yüklenen düğümün web portalına erişin ve Cluster → Members konumuna gidin. Listelenen her üyeyi kaldırın. 

  3. OVA'dan yeni bir CloudLink dağıtma

    ScaleIO 2.0.1.2 ile 6.5 P01 sürümüyle eşleşen en son CloudLink OVA'yı indirin. 

  4. Yeni CloudLink'i kümeye ekleyin

    Yeni düğümün web portalından Küme → Mevcut Kümeye Katıl'ı seçin ve geri yüklenen düğümün IP adresini ve kimlik bilgilerini sağlayın. 

Doğrulama

  • Her küme düğümünün web portalında oturum açın.
  • Cluster → Status sayfasının her iki düğümü de Sync On olarak gösterdiğini doğrulayın.
  • Security → Certificates altında geçerli bir küme sertifikasının mevcut olup olmadığını kontrol edin.
  • Hiçbir hatanın bildirilmediğinden emin olmak için hızlı bir sağlık kontrolü çalıştırın.
Dikkat: Diğer düğümler etkin durumdayken bir düğümü yedeklemeden geri yüklemek veri tutarsızlığına neden olabilir. Geri yüklemeyi yalnızca tek bir düğümde gerçekleştirin, ardından kalan üyeleri açıklandığı gibi yeniden oluşturun.
Not: Yeni OVA'yı dağıtmadan önce ana bilgisayarda yeterli disk alanı olduğunu doğrulayın. Yetersiz alan dağıtım hatalarına neden olabilir.
Uyarı: OVA dağıtımı veya CLI komutları hakkında bilginiz yoksa, istenmeyen hizmet kesintilerini önlemek için devam etmeden önce Dell Destek ile iletişime geçin.

Affected Products

CloudLink

Products

CloudLink
Article Properties
Article Number: 000034993
Article Type: Solution
Last Modified: 02 كانون الثاني 2026
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.