Avamar: Troubleshooting VMware image backup fails when user snapshot is deleted during backup
Summary: Troubleshooting VMware image backup fails when a user snapshot is deleted during backup.
Symptoms
VMware image backup failing with the following:
avvcbimage Info <14665>: 1 snapshots are present on this VM: *level=1, children=0, ref='snapshot-7553', 'VEEAM BACKUP TEMPORARY SNAPSHOT':desc='Please do not delete this snapshot.''
While backing up one or more of the data disks for a VM, the backup fails with this message:
avvcbimage Info <16041>: VDDK:<date> error -[7FFA0C431700] [Originator@6
876 sub=transport] Reconfigure attempt failed for VM "vm-21" with Vmomi::MethodFault::Exception ("vim.fault.FileNotFound")
avvcbimage Info <16041>: VDDK:VixDiskLib: Unable to locate appropriate transport mode to open disk. Error 13 (You do not have access rights to this file) at 4559.
avvcbimage Info <16041>: VDDK:VixDiskLib: VixDiskLib_OpenEx: Cannot open disk [datastore] vm/vm.vmdk. Error 13 (You do not have access rights to this file) at 4669.
avvcbimage Info <9772>: Starting graceful (staged) termination, VixDiskLib_Open attempt to connect to virtual disk failed (wrap-up stage)
Cause
In the example above, the user is backing up the same VM simultaneously using two different backup products. A process deleted users/non-avamar snapshot while Avamar backup was still running causing the disk specified in the work order to be invalid.
Example disk info from work order:
Prior Disk '2001': file(base):'[datastore] vmname/vmname_1.vmdk', backItUp=1 snapshot file:'[datastore] vmname/vmname_1-000001.vmdk' prior size(KB):52428800, current size(KB):52428800, match=1
After Avamar snapshot:
Current Disk '2001': file(base):'[datastore] vmname/vmname_1.vmdk', backItUp=1 snapshot(base) file:'[datastore] vmname/vmname_1-000001.vmdk' snapshot(curr) file:'[datastore] vmname/vmname_1-000002.vmdk' prior size(KB):52428800, current size(KB):52428800, match=1
Then the snapshot was deleted by outside process vmname_1-000001.vmdk file was deleted and thus backup failed with the file not found.
This could also occur if a normal user snapshot was deleted while backups are running.
Resolution
Do not delete snapshots while Avamar backup is running. To avoid snapshot collision like this case, we recommend to only backup a given VM using a single snapshot based backup product. If two snapshot backup products are used on the same VM, they ensure no schedule overlap.