PowerMax 2500 or 8500 Running SnapVX at PowerMaxOS 10.2.0.1 or earlier Require Upgrade
Summary: PowerMax 2500 or 8500 running SnapVX at PowerMaxOS 10.2.0.1 or lower require an upgrade to prevent snapshot failure issues.
Symptoms
The array is PowerMax 2500 or PowerMax 8500.
PowerMaxOS is 10.2.0.1 or earlier.
SnapVX is in use on the array in any capacity including:
- Snapshots
- Linked targets
- Clones
- AppSync
- PowerProtect Data Manager
A lower Health Grade in Dell AIOPs (formerly CloudIQ)
Customers without Dell AIOPs who are known to use SnapVX may be contacted individually.
EPIC environments are particularly sensitive to this issue, but any environment can be affected.
Cause
SnapVX uses Direct Index Lookup (DIL) and DIL Page Management (DPM) to handle the metadata associated with local replication. Dell Technologies has discovered a PowerMaxOS issue that can allow DPM to run out of available pages at the end of the DPM object. This issue forces the DPM to rely on free lists. This can lead to DRU situations including failed snapshots.
Older PowerMaxOS versions were not capable of automatically resolving this issue, along with additional metadata scrubbing and cleanup errors.
Resolution
PMOS-65013 has been developed to prevent this specific DPM pages issue and was included in PowerMaxOS 10.2.0.2 (released June 30, 2025)
PowerMaxOS 10.2.0.3 includes additional fixes and enhancements to prevent other known issues with SnapVX at lower microcode levels and is recommended for all SnapVX environments on these arrays. It also provides enhanced tools for automated cleanup of SnapVX metadata if issues are encountered and also tools for manual cleanup by Dell Support (for any arrays that have already encountered these issues).
NOTE: EPIC environments are particularly prone to host impact at older PowerMaxOS. EPIC customers should upgrade as soon as possible.
Contact Dell Technologies Support or your local Dell Service representative to determine whether a PowerMaxOS upgrade is appropriate for your environment. Include this article number in your ticket.