NetWorker: Licensadvarsel "Konvertering af Flexera-licens til XML-licens mislykkedes"
Summary: Der vises en NetWorker-licensfejl i NetWorker Management Console. Advarsel NetWorker x/x/x, x:xx:xx PM-registrering Konvertering af Flexera-licens til XML-licens mislykkedes. Kontakt DELL Licensing Team for at få en ny XML-licens og opdatere filen med egenskaber for licspec. Se licensvejledningen for at få flere oplysninger. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Følgende advarselsmeddelelse vises i NetWorker Management Console (NMC):
Warning NetWorker x/x/x, x:xx:xx PM registration Conversion of Flexera License to XML License failed. Please contact the DELL Licensing Team to obtain a new XML License and update the licspec properties file. Refer to the Licensing Guide for details.
Cause
Problem observeret efter serveropgradering til NetWorker version 19.13.x.
Efter opgraderingen af NetWorker-serveren til version 19.13.x blev der rapporteret en fejl relateret til licensfilkompatibilitet. I NetWorker version 19.13 og nyere er licensmekanismen blevet opdateret, så den kun understøtter .xml licensfiler. De tidligere anvendte .lic-licensfilergenkendes eller understøttes ikke længere i denne version. Som følge heraf fører forsøg på at bruge en .lic-fil efter opgradering til licensfejl eller fejl under tjenesteinitialisering.
Efter opgraderingen af NetWorker-serveren til version 19.13.x blev der rapporteret en fejl relateret til licensfilkompatibilitet. I NetWorker version 19.13 og nyere er licensmekanismen blevet opdateret, så den kun understøtter .xml licensfiler. De tidligere anvendte .lic-licensfilergenkendes eller understøttes ikke længere i denne version. Som følge heraf fører forsøg på at bruge en .lic-fil efter opgradering til licensfejl eller fejl under tjenesteinitialisering.
Resolution
Du kan løse dette problem ved at anskaffe og anvende en gyldig .xml licensfil , der er kompatibel med NetWorker 19.13.x. Du kan anmode om den opdaterede licensfil fra Dells licenssupportrepræsentant.
Når du har fået den gyldige .xml licensfil fra Dell, skal du følge nedenstående trin for at anvende den på din NetWorker-server:
- Afhængigt af operativsystemet skal du udføre følgende trin:
- I alle Linux-varianter :
- Stop NetWorker-tjenesterne.
- Rediger
licspec.propertiesfil i/nsr/lic, og tilføj følgende poster:
license.technology=XML license.path=/nsr/lic/dpa.xml
- Start NetWorker-tjenesterne.
BEMÆRK: Skift licensstien fra
/nsr/lic/dpa.lic to /nsr/lic/dpa.xml.
- I alle Windows-varianter :
- Stop NetWorker-tjenesterne.
- Rediger
licspec.propertiesfil iC:\Program Files\EMC NetWorker\nsr\lic, og tilføj følgende poster:
license.technology=XML license.path=/nsr/lic/dpa.xml
- Start NetWorker-tjenesterne.
BEMÆRK: Skift licensstien fra
/nsr/lic/dpa.lic to /nsr/lic/dpa.xml.
- Start vinduet NMC-administration på NetWorker-serveren, højreklik på serveren, og vælg derefter Egenskaber på listen. Vinduet Serveregenskaber vises.
- Vælg fanen Licensering .
- I tekstfeltet CLP-licens skal du klikke på Gennemse.
- Gå til placeringen af licensfilen, og vælg licensfilen.
- Klik på Valider licens. Knappen Valider licens deaktiveres, indtil indholdet er valideret. Du kan kontrollere status ved hjælp af
nsrlic -Ckommando.
- I vinduet Serveregenskaber under fanen Licensering skal du kontrollere, at følgende felter har de korrekte værdier, og derefter klikke på OK.
- Løsnings-id
- CLP SWID4
I vinduet NMC-administration skal du klikke på Server og derefter vælge Registreringer. Bekræft, at højre rude viser en post for CLP-kapacitetslicens, der angiver udløbsdatoen Autoriseret -Nej.
Se Dell NetWorker-licensvejledningen for at få alle oplysninger. Licensvejledningen kan findes under: Support til NetWorker | Vejledninger og dokumenter
Affected Products
NetWorker Family, NetWorkerArticle Properties
Article Number: 000348333
Article Type: Solution
Last Modified: 17 آذار 2026
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.