SRM, SRA: Chyba TestFailover se nezdařila: Vytvoření snímku Test_CG repliky se nezdařilo.

Summary: TestFailover on Storage Resource Manager (SRM) se nezdařil. Příkaz adaptéru replikace úložiště (SRA) testFailoverStart selhal pro skupinu konzistence s chybou "Failed to create snapshot of replica consistency group Test_CG. Příkaz SRA "testFailoverStart" selhal pro skupinu konzistence "Test_CG" V souboru možností byla nalezena neplatná konfigurace Další informace o chybě naleznete v protokolech EmcSrdfSra." ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Chyba v EmcSrdfSra.log:
SraDevicePairings::GetCopyInfo ] [WARNING]: A valid CopyInfo block could not be found in the options file that has Symm [0002975xxxxx]
TestFailoverStopCommand::AutoTargetDeviceProvisioning] AutoTargetDevice feature is Disabled
TestFailoverStopCommand::RunOnGroup] [ERROR]: Invalid CopyInfo type specified in TestFailoverConfig file. Exiting with failure

[20230602132024    18   304 FileExists@Utilities.cpp        ] [WARNING]: Filename:/srm/sra/conf/EmcSrdfSraTestFailoverConfig.xml
[20230602132024    18   112 main@EmcSrdfSra.cpp             ] [WARNING]: Cannot find Sra Test Failover Device Pairings configuration file. 

 

Cause

Chcete-li provést TestFailover, je důležité mít zdrojové a cílové zařízení. Zdrojovým zařízením je zařízení R2 v místě pro obnovení. Cíl je cílové zařízení snímku. 
Zde nebyla aktualizována ani EmcSrdfSraGlobalOptions.xml, ani EmcSrdfSraTestFailoverConfig.xml.

Resolution

Kroky k aktualizaci EmcSrdfSraGlobalOptions.xml:
Upravte níže uvedené parametry-
AutoTargetDevice = Yes
AutoTargetDeviceReuse = No
TerminateCopySession = Yes 
POZNÁMKA: Hodnota možnosti Opakované použití automatického cílového zařízení by měla být opačná než TerminateCopySessions jako osvědčený postup. 

NEBO

aktualizujte EmcSrdfSraTestFailoverConfig.xml. 
Příklad aktualizace EmcSrdfSraTestFailoverConfig.xml:
<CopyInfo>
<ArrayId>000190300186</ArrayId>
<CopyType>SNAPVX</CopyType>
<CopyMode>NOCOPY</CopyMode>
<SavePoolName></SavePoolName>
<DeviceList>
<DevicePair>
<Source>4D8</Source>
<Target>4DE</Target>
</DevicePair>
<DevicePair>
<Source>4D9</Source>
<Target>4DF</Target>
</DevicePair>
</DeviceList>
</CopyInfo>

Additional Information

Adaptér Dell EMC SRDF poskytuje ve složce ProgramData\EMC\EmcSrdfSra\Config následující soubory možností:
  • EmcSrdfSraGlobalOptions.xml
  • EmcSrdfSraTestFailoverConfig.xml
  • EmcSrdfSraProtectionSiteGoldCopyConfig.xml
  • EmcSrdfSraRecoverySiteGoldCopyConfig.xml
  • EmcSrdfSraDeviceMaskingControl.xml

V nejnovější verzi je lze shromáždit spuštěním nástroje SRM Appliance Management pomocí SRM_Appliance_FQDN<>:5480 > Stáhnout archiv konfigurace –
  1. Přihlaste se do rozhraní pro správu zařízení VMware SRM .
  2. Přejděte na Adaptéry> replikace úložiště Adaptér Dell EMC SRDF.
  3. Vyberte možnost Menu (tři tečky) >Download Configuration Archive.

Stáhnout archiv konfigurace

4) Stažený soubor má formát <buildname>_<buildTAG>.tar.gz.

Postup při úpravě konfiguračního archivu v systému Windows:
  1. Klikněte pravým tlačítkem na stažený <soubor buildname>_<buildTAG>.tar.gz. Otevřete soubor pomocí 7zip. 
  2. Vyberte soubor, který chcete upravit, a klikněte pravým tlačítkem na tlačítko Upravit
Upravte požadovaný soubor EmcSrdfSraGlobalOptions.xml
     3. Proveďte změny v souboru a uložte jej. 
     4. V následujících výzvách klikněte na tlačítko Ano
Výběrem možnosti Ano aktualizujte příslušný soubor xml
5. Poté je nutné soubor sradocker.tar uložit.

Kliknutím na tlačítko Ano aktualizujte sradocker.tar

       5. Nahrát archiv konfigurace
Nahrát archiv konfigurace
6. Znovu načíst-
Možnost opětovného načtení adaptéru Dell EMC SRDF v rozevírací nabídce
 
 
 

Affected Products

Storage Replication Adapter (SRA), Solutions Enabler
Article Properties
Article Number: 000228483
Article Type: Solution
Last Modified: 20 يناير 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.